* StrBufTCP_read_buffered_line_fast(): silence warning of narrow minded compilers
[citadel.git] / libcitadel / debian / rules
index 343c7a9c8494d05b08b9a25709585e8a4bee801c..e49968df514cefc6762a4483e462f6d64a7c87c6 100755 (executable)
@@ -9,8 +9,8 @@ export DH_COMPAT = 5
 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
-CFLAGS = -Wall -g
-LDFALGS = 
+CFLAGS = -Wall -g -finline-functions
+LDFALGS = -finline-functions
 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0 -ggdb -rdynamic -MD -MP -D DEBUG -D VALGRIND
        EXTRA_ARGS =  --with-backtrace