]> code.citadel.org Git - citadel.git/blob - citadel/citadel.spec
* citadel.spec: Updated for 6.20p1
[citadel.git] / citadel / citadel.spec
1 # $Id$
2 Summary: Citadel/UX, the flexible, powerful way to build online communities
3 Name: citadel
4 Version: 6.20p1
5 Release: 2
6 Copyright: GPL
7 Group: Applications/Communications
8 Source0: http://my.citadel.org/download/citadel-ux-%{PACKAGE_VERSION}.tar.gz
9 Buildroot: /var/tmp/citadel-%{PACKAGE_VERSION}-root
10 Icon: citux-64x64.xpm
11 Vendor: Citadel/UX Development Team
12 URL:  http://uncensored.citadel.org/citadel/
13 Requires: openldap-servers
14 #Autoprov: false
15 ExcludeOS: hpux
16
17 %description
18 An advanced messaging system which can be used for BBS, groupware, and
19 online community applications.  It is multithreaded, client/server, database
20 driven, and accessible via a growing selection of front ends.
21
22 %prep
23 %setup -n citadel
24
25 %build
26 CFLAGS="$RPM_OPT_FLAGS" ./configure --with-pam --enable-autologin --with-ldap --with-newt --with-libical
27 make
28
29 %install
30 rm -rf $RPM_BUILD_ROOT
31 mkdir -p $RPM_BUILD_ROOT/etc/pam.d
32 make root=$RPM_BUILD_ROOT install
33 touch $RPM_BUILD_ROOT/usr/local/citadel/.hushlogin
34 # Things that shouldn't be "installed" but were anyway
35 rm -f $RPM_BUILD_ROOT/"/usr/local/citadel/help/?"
36 rm -f $RPM_BUILD_ROOT/usr/local/citadel/README.txt
37 rm -rf $RPM_BUILD_ROOT/usr/local/citadel/docs
38 rm -rf $RPM_BUILD_ROOT/usr/local/citadel/techdoc
39
40 %clean
41 rm -rf "$RPM_BUILD_ROOT"
42
43 %package server
44 Summary: Citadel/UX, the flexible, powerful way to build online communities
45 Group: System Environment/Daemons
46 Requires: citadel-data
47 Obsoletes: citadel
48 Obsoletes: citadel-ux
49 Obsoletes: citadel-smtp
50 Obsoletes: citadel-pop3
51 Obsoletes: citadel-imap
52 Obsoletes: citadel-mrtg
53 Obsoletes: citadel-calendar
54 %description server
55 Citadel/UX is an advanced messaging system which can be used for BBS, email,
56 groupware and online community applications.  It is multithreaded,
57 client/server, database driven, and accessible via a growing selection of
58 front ends.
59 %defattr(-,root,root)
60 %files server
61 /etc/pam.d/citadel
62 %doc docs/*
63 %doc techdoc
64 %doc README.txt
65 %dir /usr/local/citadel/bio
66 %dir /usr/local/citadel/bitbucket
67 %dir /usr/local/citadel/files
68 %dir /usr/local/citadel/images
69 %dir /usr/local/citadel/info
70 %dir /usr/local/citadel/userpics
71 /usr/local/citadel/aidepost
72 /usr/local/citadel/base64
73 %attr(4755,root,root) /usr/local/citadel/chkpwd
74 /usr/local/citadel/citmail
75 /usr/local/citadel/citserver
76 /usr/local/citadel/msgform
77 /usr/local/citadel/sendcommand
78 /usr/local/citadel/setup
79 /usr/local/citadel/stress
80 /usr/local/citadel/userlist
81 /usr/local/citadel/utilsmenu
82 %pre server
83 # Add the "bbs" user
84 /usr/sbin/useradd -c "Citadel" -s /bin/false -r -d /usr/local/citadel \
85                 citadel 2> /dev/null || :
86 %post server
87 if [ -f /etc/inittab ]; then
88         if ! grep 'citserver' /etc/inittab > /dev/null; then
89                 echo "c1:2345:respawn:/usr/local/citadel/citserver -h/usr/local/citadel -x7 -llocal4" >> /etc/inittab
90         fi
91 fi
92 if [ -f /etc/services ]; then
93         if ! grep '^citadel' /etc/services > /dev/null; then
94                 echo "citadel           504/tcp         # citadel" >> /etc/services
95         fi
96 fi
97 cd /usr/local/citadel
98 /usr/local/citadel/setup -q
99 %postun server
100 if [ -f /etc/inittab ]; then
101         grep -v 'citserver' < /etc/inittab > /etc/inittab.new && \
102         mv -f /etc/inittab.new /etc/inittab
103         /sbin/init q
104 fi
105
106 %package data
107 Summary: Data files for the Citadel/UX messaging system.
108 Group: System Environment/Daemons
109 %description data
110 Default data files for the Citadel/UX messaging system.  These files are
111 required by the Citadel/UX server.
112 %defattr(-,root,root)
113 %files data
114 /usr/local/citadel/.hushlogin
115 #%dir /usr/local/citadel/netconfigs
116 %dir /usr/local/citadel/network
117 %dir /usr/local/citadel/network/spoolin
118 %dir /usr/local/citadel/network/spoolout
119 %dir /usr/local/citadel/network/systems
120 %config(noreplace) /usr/local/citadel/network/filterlist
121 %config(noreplace) /usr/local/citadel/network/mail.aliases
122 %config(noreplace) /usr/local/citadel/network/mailinglists
123 %config(noreplace) /usr/local/citadel/network/rnews.xref
124 %config(noreplace) /usr/local/citadel/public_clients
125 %config /usr/local/citadel/help/aide
126 %config /usr/local/citadel/help/software
127 %config /usr/local/citadel/help/floors
128 %config(noreplace) /usr/local/citadel/help/hours
129 %config /usr/local/citadel/help/intro
130 %config /usr/local/citadel/help/mail
131 %config /usr/local/citadel/help/network
132 %config /usr/local/citadel/help/nice
133 %config(noreplace) /usr/local/citadel/help/policy
134 %config /usr/local/citadel/help/summary
135 %config(noreplace) /usr/local/citadel/messages/changepw
136 %config /usr/local/citadel/messages/aideopt
137 %config(noreplace) /usr/local/citadel/messages/entermsg
138 %config /usr/local/citadel/messages/dotopt
139 %config /usr/local/citadel/messages/mainmenu
140 %config /usr/local/citadel/messages/entopt
141 %config(noreplace) /usr/local/citadel/messages/goodbye
142 %config(noreplace) /usr/local/citadel/messages/hello
143 %config /usr/local/citadel/messages/help
144 %config(noreplace) /usr/local/citadel/messages/register
145 %config(noreplace) /usr/local/citadel/messages/newuser
146 %config /usr/local/citadel/messages/readopt
147 %config(noreplace) /usr/local/citadel/messages/roomaccess
148 %config(noreplace) /usr/local/citadel/messages/unlisted
149 %post data
150 # Yes, this is supposed to be executed twice; as ? might not yet exist
151 # but we want it to be listed.  It's kludgey; sue me.
152 /bin/ls /usr/local/citadel/help > "/usr/local/citadel/help/?"
153 /bin/ls /usr/local/citadel/help > "/usr/local/citadel/help/?"
154
155 %package client
156 Summary: Client for the Citadel/UX messaging system
157 Group: Applications/Communications
158 %description client
159 This is the text client software for the Citadel/UX messaging system.
160 Install this software if you need to connect to a Citadel/UX server.
161 %defattr(-,root,root)
162 %files client
163 /usr/local/citadel/citadel
164 /usr/local/citadel/citadel.rc
165 /usr/local/citadel/whobbs
166 %post client
167 if [ -f /etc/services ]; then
168         if ! grep '^citadel' /etc/services > /dev/null; then
169                 echo "citadel           504/tcp         # citadel" >> /etc/services
170         fi
171 fi