]> code.citadel.org Git - citadel.git/blob - citadel/citadel.spec
* Removed the 'netsetup' and 'dnetsetup' utilities (obsolete)
[citadel.git] / citadel / citadel.spec
1 # $Id$
2 Summary: Citadel/UX, the flexible, powerful way to build online communities
3 Name: citadel
4 Version: 5.90
5 Release: 1
6 Copyright: GPL
7 Group: Applications/Communications
8 Source0: http://uncensored.citadel.org/pub/citadel/citadel-ux-%{PACKAGE_VERSION}.tar.gz
9 Buildroot: /var/tmp/citadel-%{PACKAGE_VERSION}-root
10 Icon: citux-64x64.xpm
11 Vendor: Citadel/UX Development Team
12 URL:  http://uncensored.citadel.org/citadel/
13 #Autoprov: false
14 ExcludeOS: hpux
15
16 %description
17 An advanced messaging system which can be used for BBS, groupware, and
18 online community applications.  It is multithreaded, client/server, database
19 driven, and accessible via a growing selection of front ends.
20
21 %prep
22 %setup -n citadel
23
24 %build
25 CFLAGS="$RPM_OPT_FLAGS" ./configure --with-pam
26 make
27
28 %install
29 rm -rf $RPM_BUILD_ROOT
30 mkdir -p $RPM_BUILD_ROOT/etc/pam.d
31 make root=$RPM_BUILD_ROOT install
32 touch $RPM_BUILD_ROOT/usr/local/citadel/.hushlogin
33
34 %clean
35 rm -rf "$RPM_BUILD_ROOT"
36
37 %package server
38 Summary: Citadel/UX, the flexible, powerful way to build online communities
39 Group: System Environment/Daemons
40 Requires: citadel-data
41 Obsoletes: citadel
42 Obsoletes: citadel-ux
43 %description server
44 Citadel/UX is an advanced messaging system which can be used for BBS,
45 groupware, and online community applications.  It is multithreaded,
46 client/server, database driven, and accessible via a growing selection of
47 front ends.  Remember to run /usr/local/citadel/setup after installing or
48 upgrading this package.
49 %defattr(-,root,root)
50 %files server
51 /etc/pam.d/citadel
52 %doc docs/chat.txt
53 %doc docs/citadel-with-berkeley-db.txt
54 %doc docs/COPYING.txt
55 %doc docs/copyright.txt
56 %doc docs/import-export.txt
57 %doc docs/inetsiteconfig.txt
58 %doc docs/mailinglists.txt
59 %doc docs/room-sharing-howto.txt
60 %doc docs/siteconfig.txt
61 %doc docs/sysop.txt
62 %doc docs/upgrading.txt
63 %doc docs/utils.txt
64 %dir /usr/local/citadel/bio
65 %dir /usr/local/citadel/bitbucket
66 %dir /usr/local/citadel/files
67 %dir /usr/local/citadel/images
68 %dir /usr/local/citadel/info
69 %dir /usr/local/citadel/userpics
70 /usr/local/citadel/aidepost
71 /usr/local/citadel/base64
72 %attr(4755,root,root) /usr/local/citadel/chkpwd
73 /usr/local/citadel/citmail
74 /usr/local/citadel/citserver
75 /usr/local/citadel/libcitserver.so
76 /usr/local/citadel/libcitserver.la
77 /usr/local/citadel/migratenet
78 /usr/local/citadel/msgform
79 /usr/local/citadel/readlog
80 /usr/local/citadel/sendcommand
81 /usr/local/citadel/setup
82 /usr/local/citadel/stats
83 /usr/local/citadel/userlist
84 /usr/local/citadel/utilsmenu
85 /usr/local/citadel/weekly
86 /usr/local/citadel/modules/libchat.so
87 /usr/local/citadel/modules/libchat.la
88 /usr/local/citadel/modules/libvcard.so
89 /usr/local/citadel/modules/libvcard.la
90 /usr/local/citadel/modules/libupgrade.so
91 /usr/local/citadel/modules/libupgrade.la
92 /usr/local/citadel/modules/libnetwork.so
93 /usr/local/citadel/modules/libnetwork.la
94 /usr/local/citadel/modules/libpas2.so
95 /usr/local/citadel/modules/libpas2.la
96 /usr/local/citadel/modules/libinetcfg.so
97 /usr/local/citadel/modules/libinetcfg.la
98 /usr/local/citadel/modules/librwho.so
99 /usr/local/citadel/modules/librwho.la
100 /usr/local/citadel/modules/libmoderate.so
101 /usr/local/citadel/modules/libmoderate.la
102 /usr/local/citadel/modules/libbio.so
103 /usr/local/citadel/modules/libbio.la
104 /usr/local/citadel/modules/libexpire.so
105 /usr/local/citadel/modules/libexpire.la
106 /usr/local/citadel/modules/libvandelay.so
107 /usr/local/citadel/modules/libvandelay.la
108 /usr/local/citadel/modules/libical.so
109 /usr/local/citadel/modules/libical.la
110 %pre server
111 # Add the "bbs" user
112 /usr/sbin/useradd -c "Citadel" -s /bin/false -r -d /usr/local/citadel \
113                 citadel 2> /dev/null || :
114 %post server
115 if [ -f /etc/inittab ]; then
116         if ! grep 'citserver' /etc/inittab > /dev/null; then
117                 echo "c1:2345:/usr/local/citadel/citserver -h/usr/local/citadel -t/usr/local/citadel/citserver.trace" >> /etc/inittab
118         fi
119 fi
120 if [ -f /etc/services ]; then
121         if ! grep '^citadel' /etc/services > /dev/null; then
122                 echo "citadel           504/tcp         # citadel" >> /etc/services
123         fi
124 fi
125 /sbin/ldconfig -n /usr/local/citadel /usr/local/citadel/modules
126 cd /usr/local/citadel
127 /usr/local/citadel/setup -q
128 %postun server
129 if [ -f /etc/inittab ]; then
130         grep -v 'citserver' < /etc/inittab > /etc/inittab.new
131         mv /etc/inittab.new /etc/inittab
132         /sbin/init q
133 fi
134
135 %package data
136 Summary: Data files for the Citadel/UX messaging system.
137 Group: System Environment/Daemons
138 %description data
139 Default data files for the Citadel/UX messaging system.  These files are
140 required by the Citadel/UX server.
141 %defattr(-,root,root)
142 %files data
143 /usr/local/citadel/.hushlogin
144 #%dir /usr/local/citadel/netconfigs
145 %dir /usr/local/citadel/network
146 %dir /usr/local/citadel/network/spoolin
147 %dir /usr/local/citadel/network/spoolout
148 %dir /usr/local/citadel/network/systems
149 %config(noreplace) /usr/local/citadel/network/filterlist
150 %config(noreplace) /usr/local/citadel/network/mail.aliases
151 %config(noreplace) /usr/local/citadel/network/mailinglists
152 %config(noreplace) /usr/local/citadel/network/rnews.xref
153 %config(noreplace) /usr/local/citadel/public_clients
154 # KLUDGE!!!!  This catches help/? otherwise RPM barfs on it
155 # Drawback, it's not marked as a config file, oh well
156 /usr/local/citadel/help
157 #%config /usr/local/citadel/help/?
158 #%config /usr/local/citadel/help/aide
159 #%config /usr/local/citadel/help/software
160 #%config /usr/local/citadel/help/floors
161 #%config(noreplace) /usr/local/citadel/help/hours
162 #%config /usr/local/citadel/help/intro
163 #%config /usr/local/citadel/help/mail
164 #%config /usr/local/citadel/help/network
165 #%config /usr/local/citadel/help/nice
166 #%config(noreplace) /usr/local/citadel/help/policy
167 #%config /usr/local/citadel/help/summary
168 %config /usr/local/citadel/messages/changepw
169 %config /usr/local/citadel/messages/aideopt
170 %config /usr/local/citadel/messages/entermsg
171 %config /usr/local/citadel/messages/dotopt
172 %config /usr/local/citadel/messages/mainmenu
173 %config /usr/local/citadel/messages/entopt
174 %config(noreplace) /usr/local/citadel/messages/goodbye
175 %config(noreplace) /usr/local/citadel/messages/hello
176 %config /usr/local/citadel/messages/help
177 %config(noreplace) /usr/local/citadel/messages/register
178 %config(noreplace) /usr/local/citadel/messages/newuser
179 %config /usr/local/citadel/messages/readopt
180 %config /usr/local/citadel/messages/roomaccess
181 %config(noreplace) /usr/local/citadel/messages/unlisted
182
183 %package client
184 Summary: Client for the Citadel/UX messaging system
185 Group: Applications/Communications
186 %description client
187 This is the text client software for the Citadel/UX messaging system.
188 Install this software if you need to connect to a Citadel/UX server.
189 %defattr(-,root,root)
190 %files client
191 /usr/local/citadel/citadel
192 /usr/local/citadel/citadel.rc
193 %doc docs/chat.txt
194 %post client
195 if [ -f /etc/services ]; then
196         if ! grep '^citadel' /etc/services > /dev/null; then
197                 echo "citadel           504/tcp         # citadel" >> /etc/services
198         fi
199 fi
200
201 %package smtp
202 Summary: SMTP server for the Citadel/UX messaging system
203 Group: System Environment/Daemons
204 %description smtp
205 This package provides the Citadel/UX SMTP service, which provides inbound
206 and outbound SMTP service for the Citadel/UX messaging system.  Install this
207 package if your Citadel/UX users should be able to send and receive Internet
208 e-mail.  If you also run another SMTP server you will need to read
209 docs/inetmailsetupmx.txt to configure SMTP service.
210 %defattr(-,root,root)
211 %files smtp
212 /usr/local/citadel/modules/libsmtp.so
213 /usr/local/citadel/modules/libsmtp.la
214 %doc docs/inetmailsetupmx.txt
215 %doc docs/inetmailsetup.txt
216
217 %package imap
218 Summary: IMAP server for the Citadel/UX messaging system
219 Group: System Environment/Daemons
220 %description imap
221 This package provides the Citadel/UX IMAP service, which provides IMAP
222 connectivity.  Install this package if you want to connect to the Citadel/UX
223 server with IMAP clients such as Outlook Express or Netscape.  Using this
224 access method, users can access both e-mail and all public rooms on the server.
225 %defattr(-,root,root)
226 %files imap
227 /usr/local/citadel/modules/libimap.so
228 /usr/local/citadel/modules/libimap.la
229
230 %package pop3
231 Summary: POP3 server for the Citadel/UX messaging system
232 Group: System Environment/Daemons
233 %description pop3
234 This package provides the Citadel/UX POP3 service, which provides POP3
235 connectivity.  Install this package if you want to connect to the Citadel/UX
236 server with POP3 clients such as Outlook Express or Netscape.  Note that the
237 POP3 client can only receive mail; install citadel-smtp as well if you want
238 users to be able to send mail.
239 %defattr(-,root,root)
240 %files pop3
241 /usr/local/citadel/modules/libpop3.so
242 /usr/local/citadel/modules/libpop3.la
243