]> code.citadel.org Git - citadel.git/blob - citadel/citadel.spec
* Removed the "weekly" script and began installing a facility to allow
[citadel.git] / citadel / citadel.spec
1 # $Id$
2 Summary: Citadel/UX, the flexible, powerful way to build online communities
3 Name: citadel
4 Version: 6.01a
5 Release: 1
6 Copyright: GPL
7 Group: Applications/Communications
8 Source0: http://uncensored.citadel.org/pub/citadel/citadel-ux-%{PACKAGE_VERSION}.tar.gz
9 Buildroot: /var/tmp/citadel-%{PACKAGE_VERSION}-root
10 Icon: citux-64x64.xpm
11 Vendor: Citadel/UX Development Team
12 URL:  http://uncensored.citadel.org/citadel/
13 #Autoprov: false
14 ExcludeOS: hpux
15
16 %description
17 An advanced messaging system which can be used for BBS, groupware, and
18 online community applications.  It is multithreaded, client/server, database
19 driven, and accessible via a growing selection of front ends.
20
21 %prep
22 %setup -n citadel
23
24 %build
25 CFLAGS="$RPM_OPT_FLAGS" ./configure --with-pam
26 make
27
28 %install
29 rm -rf $RPM_BUILD_ROOT
30 mkdir -p $RPM_BUILD_ROOT/etc/pam.d
31 make root=$RPM_BUILD_ROOT install
32 touch $RPM_BUILD_ROOT/usr/local/citadel/.hushlogin
33
34 %clean
35 rm -rf "$RPM_BUILD_ROOT"
36
37 %package server
38 Summary: Citadel/UX, the flexible, powerful way to build online communities
39 Group: System Environment/Daemons
40 Requires: citadel-data
41 Obsoletes: citadel
42 Obsoletes: citadel-ux
43 %description server
44 Citadel/UX is an advanced messaging system which can be used for BBS,
45 groupware, and online community applications.  It is multithreaded,
46 client/server, database driven, and accessible via a growing selection of
47 front ends.  Remember to run /usr/local/citadel/setup after installing or
48 upgrading this package.
49 %defattr(-,root,root)
50 %files server
51 /etc/pam.d/citadel
52 %doc docs/chat.txt
53 %doc docs/citadel-with-berkeley-db.txt
54 %doc docs/COPYING.txt
55 %doc docs/copyright.txt
56 %doc docs/import-export.txt
57 %doc docs/inetsiteconfig.txt
58 %doc docs/mailinglists.txt
59 %doc docs/room-sharing-howto.txt
60 %doc docs/siteconfig.txt
61 %doc docs/sysop.txt
62 %doc docs/upgrading.txt
63 %doc docs/utils.txt
64 %dir /usr/local/citadel/bio
65 %dir /usr/local/citadel/bitbucket
66 %dir /usr/local/citadel/files
67 %dir /usr/local/citadel/images
68 %dir /usr/local/citadel/info
69 %dir /usr/local/citadel/userpics
70 /usr/local/citadel/aidepost
71 /usr/local/citadel/base64
72 %attr(4755,root,root) /usr/local/citadel/chkpwd
73 /usr/local/citadel/citmail
74 /usr/local/citadel/citserver
75 /usr/local/citadel/libcitserver.so
76 /usr/local/citadel/libcitserver.la
77 /usr/local/citadel/migratenet
78 /usr/local/citadel/msgform
79 /usr/local/citadel/readlog
80 /usr/local/citadel/sendcommand
81 /usr/local/citadel/setup
82 /usr/local/citadel/stats
83 /usr/local/citadel/userlist
84 /usr/local/citadel/utilsmenu
85 /usr/local/citadel/modules/libbio.so
86 /usr/local/citadel/modules/libbio.la
87 /usr/local/citadel/modules/libchat.so
88 /usr/local/citadel/modules/libchat.la
89 /usr/local/citadel/modules/libexpire.so
90 /usr/local/citadel/modules/libexpire.la
91 /usr/local/citadel/modules/libinetcfg.so
92 /usr/local/citadel/modules/libinetcfg.la
93 /usr/local/citadel/modules/liblistsub.so
94 /usr/local/citadel/modules/liblistsub.la
95 /usr/local/citadel/modules/libnetfilter.so
96 /usr/local/citadel/modules/libnetfilter.la
97 /usr/local/citadel/modules/libnetwork.so
98 /usr/local/citadel/modules/libnetwork.la
99 /usr/local/citadel/modules/libpas2.so
100 /usr/local/citadel/modules/libpas2.la
101 /usr/local/citadel/modules/librwho.so
102 /usr/local/citadel/modules/librwho.la
103 /usr/local/citadel/modules/libspam.so
104 /usr/local/citadel/modules/libspam.la
105 /usr/local/citadel/modules/libupgrade.so
106 /usr/local/citadel/modules/libupgrade.la
107 /usr/local/citadel/modules/libvandelay.so
108 /usr/local/citadel/modules/libvandelay.la
109 /usr/local/citadel/modules/libvcard.so
110 /usr/local/citadel/modules/libvcard.la
111 %pre server
112 # Add the "bbs" user
113 /usr/sbin/useradd -c "Citadel" -s /bin/false -r -d /usr/local/citadel \
114                 citadel 2> /dev/null || :
115 %post server
116 if [ -f /etc/inittab ]; then
117         if ! grep 'citserver' /etc/inittab > /dev/null; then
118                 echo "c1:2345:/usr/local/citadel/citserver -h/usr/local/citadel -t/usr/local/citadel/citserver.trace" >> /etc/inittab
119         fi
120 fi
121 if [ -f /etc/services ]; then
122         if ! grep '^citadel' /etc/services > /dev/null; then
123                 echo "citadel           504/tcp         # citadel" >> /etc/services
124         fi
125 fi
126 /sbin/ldconfig -n /usr/local/citadel /usr/local/citadel/modules
127 cd /usr/local/citadel
128 /usr/local/citadel/setup -q
129 %postun server
130 if [ -f /etc/inittab ]; then
131         grep -v 'citserver' < /etc/inittab > /etc/inittab.new && \
132         mv -f /etc/inittab.new /etc/inittab
133         /sbin/init q
134 fi
135
136 %package data
137 Summary: Data files for the Citadel/UX messaging system.
138 Group: System Environment/Daemons
139 %description data
140 Default data files for the Citadel/UX messaging system.  These files are
141 required by the Citadel/UX server.
142 %defattr(-,root,root)
143 %files data
144 /usr/local/citadel/.hushlogin
145 #%dir /usr/local/citadel/netconfigs
146 %dir /usr/local/citadel/network
147 %dir /usr/local/citadel/network/spoolin
148 %dir /usr/local/citadel/network/spoolout
149 %dir /usr/local/citadel/network/systems
150 %config(noreplace) /usr/local/citadel/network/filterlist
151 %config(noreplace) /usr/local/citadel/network/mail.aliases
152 %config(noreplace) /usr/local/citadel/network/mailinglists
153 %config(noreplace) /usr/local/citadel/network/rnews.xref
154 %config(noreplace) /usr/local/citadel/public_clients
155 %config /usr/local/citadel/help/aide
156 %config /usr/local/citadel/help/software
157 %config /usr/local/citadel/help/floors
158 %config(noreplace) /usr/local/citadel/help/hours
159 %config /usr/local/citadel/help/intro
160 %config /usr/local/citadel/help/mail
161 %config /usr/local/citadel/help/network
162 %config /usr/local/citadel/help/nice
163 %config(noreplace) /usr/local/citadel/help/policy
164 %config /usr/local/citadel/help/summary
165 %config(noreplace) /usr/local/citadel/messages/changepw
166 %config /usr/local/citadel/messages/aideopt
167 %config(noreplace) /usr/local/citadel/messages/entermsg
168 %config /usr/local/citadel/messages/dotopt
169 %config /usr/local/citadel/messages/mainmenu
170 %config /usr/local/citadel/messages/entopt
171 %config(noreplace) /usr/local/citadel/messages/goodbye
172 %config(noreplace) /usr/local/citadel/messages/hello
173 %config /usr/local/citadel/messages/help
174 %config(noreplace) /usr/local/citadel/messages/register
175 %config(noreplace) /usr/local/citadel/messages/newuser
176 %config /usr/local/citadel/messages/readopt
177 %config(noreplace) /usr/local/citadel/messages/roomaccess
178 %config(noreplace) /usr/local/citadel/messages/unlisted
179 %post data
180 # Yes, this is supposed to be executed twice; as ? might not yet exist
181 # but we want it to be listed.  It's kludgey; sue me.
182 ls /usr/local/citadel/help > "/usr/local/citadel/help/?"
183 ls /usr/local/citadel/help > "/usr/local/citadel/help/?"
184
185 %package client
186 Summary: Client for the Citadel/UX messaging system
187 Group: Applications/Communications
188 %description client
189 This is the text client software for the Citadel/UX messaging system.
190 Install this software if you need to connect to a Citadel/UX server.
191 %defattr(-,root,root)
192 %files client
193 /usr/local/citadel/citadel
194 /usr/local/citadel/citadel.rc
195 %doc docs/chat.txt
196 %post client
197 if [ -f /etc/services ]; then
198         if ! grep '^citadel' /etc/services > /dev/null; then
199                 echo "citadel           504/tcp         # citadel" >> /etc/services
200         fi
201 fi
202
203 %package smtp
204 Summary: SMTP server for the Citadel/UX messaging system
205 Group: System Environment/Daemons
206 Requires: citadel-server
207 %description smtp
208 This package provides the Citadel/UX SMTP service, which provides inbound
209 and outbound SMTP service for the Citadel/UX messaging system.  Install this
210 package if your Citadel/UX users should be able to send and receive Internet
211 e-mail.  If you also run another SMTP server you will need to read
212 docs/inetmailsetupmx.txt to configure SMTP service.
213 %defattr(-,root,root)
214 %files smtp
215 /usr/local/citadel/modules/libsmtp.so
216 /usr/local/citadel/modules/libsmtp.la
217 %doc docs/inetmailsetupmx.txt
218 %doc docs/inetmailsetup.txt
219
220 %package imap
221 Summary: IMAP server for the Citadel/UX messaging system
222 Group: System Environment/Daemons
223 Requires: citadel-server
224 %description imap
225 This package provides the Citadel/UX IMAP service, which provides IMAP
226 connectivity.  Install this package if you want to connect to the Citadel/UX
227 server with IMAP clients such as Outlook Express or Netscape.  Using this
228 access method, users can access both e-mail and all public rooms on the server.
229 %defattr(-,root,root)
230 %files imap
231 /usr/local/citadel/modules/libimap.so
232 /usr/local/citadel/modules/libimap.la
233
234 %package pop3
235 Summary: POP3 server for the Citadel/UX messaging system
236 Group: System Environment/Daemons
237 Requires: citadel-server
238 %description pop3
239 This package provides the Citadel/UX POP3 service, which provides POP3
240 connectivity.  Install this package if you want to connect to the Citadel/UX
241 server with POP3 clients such as Outlook Express or Netscape.  Note that the
242 POP3 client can only receive mail; install citadel-smtp as well if you want
243 users to be able to send mail.
244 %defattr(-,root,root)
245 %files pop3
246 /usr/local/citadel/modules/libpop3.so
247 /usr/local/citadel/modules/libpop3.la
248
249 %package mrtg
250 Summary: Export Citadel/UX statistics to MRTG
251 Group: System Environment/Daemons
252 Requires: citadel-server
253 Requires: mrtg
254 %description mrtg
255 This package allows Citadel/UX to export server statistics in a format
256 compatible with the Multi Router Traffic Grapher.
257 %files mrtg
258 /usr/local/citadel/modules/libmrtg.so
259 /usr/local/citadel/modules/libmrtg.la
260
261 %package calendar
262 Summary: Citadel/UX calendaring and scheduling services
263 Group: System Environment/Daemons
264 Requires: citadel-server
265 Requires: libical.so
266 %description calendar
267 This package provides calendaring and scheduling services for Citadel/UX.
268 It will interoperate with other calendaring packages that support the Internet
269 standard vCalendar formats.  Currently only meeting scheduling is supported.
270 (This is an experimental package!)
271 %files calendar
272 /usr/local/citadel/modules/libcalendar.so
273 /usr/local/citadel/modules/libcalendar.la
274