]> code.citadel.org Git - citadel.git/blob - citadel/citadel.spec
* citadel.spec cleaned up
[citadel.git] / citadel / citadel.spec
1 # $Id$
2 Summary: Citadel/UX, the flexible, powerful way to build online communities
3 Name: citadel
4 Version: 5.90
5 Release: 1
6 Copyright: GPL
7 Group: Applications/Communications
8 Source0: http://uncensored.citadel.org/pub/citadel/citadel-ux-%{PACKAGE_VERSION}.tar.gz
9 Buildroot: /var/tmp/citadel-%{PACKAGE_VERSION}-root
10 Icon: citux-64x64.xpm
11 Vendor: Citadel/UX Development Team
12 URL:  http://uncensored.citadel.org/citadel/
13 #Autoprov: false
14 ExcludeOS: hpux
15
16 %description
17 An advanced messaging system which can be used for BBS, groupware, and
18 online community applications.  It is multithreaded, client/server, database
19 driven, and accessible via a growing selection of front ends.
20
21 %prep
22 %setup -n citadel
23
24 %build
25 CFLAGS="$RPM_OPT_FLAGS" ./configure --with-pam
26 make
27
28 %install
29 rm -rf $RPM_BUILD_ROOT
30 mkdir -p $RPM_BUILD_ROOT/etc/pam.d
31 make root=$RPM_BUILD_ROOT install
32 touch $RPM_BUILD_ROOT/usr/local/citadel/.hushlogin
33
34 %clean
35 rm -rf "$RPM_BUILD_ROOT"
36
37 %package server
38 Summary: Citadel/UX, the flexible, powerful way to build online communities
39 Group: System Environment/Daemons
40 Requires: citadel-data
41 Obsoletes: citadel
42 Obsoletes: citadel-ux
43 %description server
44 Citadel/UX is an advanced messaging system which can be used for BBS,
45 groupware, and online community applications.  It is multithreaded,
46 client/server, database driven, and accessible via a growing selection of
47 front ends.  Remember to run /usr/local/citadel/setup after installing or
48 upgrading this package.
49 %defattr(-,root,root)
50 %files server
51 /etc/pam.d/citadel
52 %doc docs/chat.txt
53 %doc docs/citadel-with-berkeley-db.txt
54 %doc docs/COPYING.txt
55 %doc docs/copyright.txt
56 %doc docs/import-export.txt
57 %doc docs/inetsiteconfig.txt
58 %doc docs/mailinglists.txt
59 %doc docs/room-sharing-howto.txt
60 %doc docs/siteconfig.txt
61 %doc docs/sysop.txt
62 %doc docs/upgrading.txt
63 %doc docs/utils.txt
64 %dir /usr/local/citadel/bio
65 %dir /usr/local/citadel/bitbucket
66 %dir /usr/local/citadel/files
67 %dir /usr/local/citadel/images
68 %dir /usr/local/citadel/info
69 %dir /usr/local/citadel/userpics
70 /usr/local/citadel/aidepost
71 /usr/local/citadel/base64
72 %attr(4755,root,root) /usr/local/citadel/chkpwd
73 /usr/local/citadel/citmail
74 /usr/local/citadel/citserver
75 /usr/local/citadel/dnetsetup
76 /usr/local/citadel/libcitserver.so
77 /usr/local/citadel/libcitserver.la
78 /usr/local/citadel/migratenet
79 /usr/local/citadel/msgform
80 /usr/local/citadel/netsetup
81 /usr/local/citadel/readlog
82 /usr/local/citadel/sendcommand
83 /usr/local/citadel/setup
84 /usr/local/citadel/stats
85 /usr/local/citadel/userlist
86 /usr/local/citadel/utilsmenu
87 /usr/local/citadel/weekly
88 /usr/local/citadel/modules/libchat.so
89 /usr/local/citadel/modules/libchat.la
90 /usr/local/citadel/modules/libvcard.so
91 /usr/local/citadel/modules/libvcard.la
92 /usr/local/citadel/modules/libupgrade.so
93 /usr/local/citadel/modules/libupgrade.la
94 /usr/local/citadel/modules/libnetwork.so
95 /usr/local/citadel/modules/libnetwork.la
96 /usr/local/citadel/modules/libpas2.so
97 /usr/local/citadel/modules/libpas2.la
98 /usr/local/citadel/modules/libinetcfg.so
99 /usr/local/citadel/modules/libinetcfg.la
100 /usr/local/citadel/modules/librwho.so
101 /usr/local/citadel/modules/librwho.la
102 /usr/local/citadel/modules/libmoderate.so
103 /usr/local/citadel/modules/libmoderate.la
104 /usr/local/citadel/modules/libbio.so
105 /usr/local/citadel/modules/libbio.la
106 /usr/local/citadel/modules/libexpire.so
107 /usr/local/citadel/modules/libexpire.la
108 /usr/local/citadel/modules/libvandelay.so
109 /usr/local/citadel/modules/libvandelay.la
110 /usr/local/citadel/modules/libical.so
111 /usr/local/citadel/modules/libical.la
112 %pre server
113 # Add the "bbs" user
114 /usr/sbin/useradd -c "Citadel" -s /bin/false -r -d /usr/local/citadel \
115                 citadel 2> /dev/null || :
116 %post server
117 if [ -f /etc/inittab ]; then
118         if ! grep 'citserver' /etc/inittab > /dev/null; then
119                 echo "c1:2345:/usr/local/citadel/citserver -h/usr/local/citadel -t/usr/local/citadel/citserver.trace" >> /etc/inittab
120         fi
121 fi
122 if [ -f /etc/services ]; then
123         if ! grep '^citadel' /etc/services > /dev/null; then
124                 echo "citadel           504/tcp         # citadel" >> /etc/services
125         fi
126 fi
127 /sbin/ldconfig -n /usr/local/citadel /usr/local/citadel/modules
128 cd /usr/local/citadel
129 /usr/local/citadel/setup -q
130 %postun server
131 if [ -f /etc/inittab ]; then
132         grep -v 'citserver' < /etc/inittab > /etc/inittab.new
133         mv /etc/inittab.new /etc/inittab
134         /sbin/init q
135 fi
136
137 %package data
138 Summary: Data files for the Citadel/UX messaging system.
139 Group: System Environment/Daemons
140 %description data
141 Default data files for the Citadel/UX messaging system.  These files are
142 required by the Citadel/UX server.
143 %defattr(-,root,root)
144 %files data
145 /usr/local/citadel/.hushlogin
146 #%dir /usr/local/citadel/netconfigs
147 %dir /usr/local/citadel/network
148 %dir /usr/local/citadel/network/spoolin
149 %dir /usr/local/citadel/network/spoolout
150 %dir /usr/local/citadel/network/systems
151 %config(noreplace) /usr/local/citadel/network/filterlist
152 %config(noreplace) /usr/local/citadel/network/mail.aliases
153 %config(noreplace) /usr/local/citadel/network/mailinglists
154 %config(noreplace) /usr/local/citadel/network/rnews.xref
155 %config(noreplace) /usr/local/citadel/public_clients
156 # KLUDGE!!!!  This catches help/? otherwise RPM barfs on it
157 # Drawback, it's not marked as a config file, oh well
158 /usr/local/citadel/help
159 #%config /usr/local/citadel/help/?
160 #%config /usr/local/citadel/help/aide
161 #%config /usr/local/citadel/help/software
162 #%config /usr/local/citadel/help/floors
163 #%config(noreplace) /usr/local/citadel/help/hours
164 #%config /usr/local/citadel/help/intro
165 #%config /usr/local/citadel/help/mail
166 #%config /usr/local/citadel/help/network
167 #%config /usr/local/citadel/help/nice
168 #%config(noreplace) /usr/local/citadel/help/policy
169 #%config /usr/local/citadel/help/summary
170 %config /usr/local/citadel/messages/changepw
171 %config /usr/local/citadel/messages/aideopt
172 %config /usr/local/citadel/messages/entermsg
173 %config /usr/local/citadel/messages/dotopt
174 %config /usr/local/citadel/messages/mainmenu
175 %config /usr/local/citadel/messages/entopt
176 %config(noreplace) /usr/local/citadel/messages/goodbye
177 %config(noreplace) /usr/local/citadel/messages/hello
178 %config /usr/local/citadel/messages/help
179 %config(noreplace) /usr/local/citadel/messages/register
180 %config(noreplace) /usr/local/citadel/messages/newuser
181 %config /usr/local/citadel/messages/readopt
182 %config /usr/local/citadel/messages/roomaccess
183 %config(noreplace) /usr/local/citadel/messages/unlisted
184
185 %package client
186 Summary: Client for the Citadel/UX messaging system
187 Group: Applications/Communications
188 %description client
189 This is the text client software for the Citadel/UX messaging system.
190 Install this software if you need to connect to a Citadel/UX server.
191 %defattr(-,root,root)
192 %files client
193 /usr/local/citadel/citadel
194 /usr/local/citadel/citadel.rc
195 %doc docs/chat.txt
196 %post client
197 if [ -f /etc/services ]; then
198         if ! grep '^citadel' /etc/services > /dev/null; then
199                 echo "citadel           504/tcp         # citadel" >> /etc/services
200         fi
201 fi
202
203 %package smtp
204 Summary: SMTP server for the Citadel/UX messaging system
205 Group: System Environment/Daemons
206 %description smtp
207 This package provides the Citadel/UX SMTP service, which provides inbound
208 and outbound SMTP service for the Citadel/UX messaging system.  Install this
209 package if your Citadel/UX users should be able to send and receive Internet
210 e-mail.  If you also run another SMTP server you will need to read
211 docs/inetmailsetupmx.txt to configure SMTP service.
212 %defattr(-,root,root)
213 %files smtp
214 /usr/local/citadel/modules/libsmtp.so
215 /usr/local/citadel/modules/libsmtp.la
216 %doc docs/inetmailsetupmx.txt
217 %doc docs/inetmailsetup.txt
218
219 %package imap
220 Summary: IMAP server for the Citadel/UX messaging system
221 Group: System Environment/Daemons
222 %description imap
223 This package provides the Citadel/UX IMAP service, which provides IMAP
224 connectivity.  Install this package if you want to connect to the Citadel/UX
225 server with IMAP clients such as Outlook Express or Netscape.  Using this
226 access method, users can access both e-mail and all public rooms on the server.
227 %defattr(-,root,root)
228 %files imap
229 /usr/local/citadel/modules/libimap.so
230 /usr/local/citadel/modules/libimap.la
231
232 %package pop3
233 Summary: POP3 server for the Citadel/UX messaging system
234 Group: System Environment/Daemons
235 %description pop3
236 This package provides the Citadel/UX POP3 service, which provides POP3
237 connectivity.  Install this package if you want to connect to the Citadel/UX
238 server with POP3 clients such as Outlook Express or Netscape.  Note that the
239 POP3 client can only receive mail; install citadel-smtp as well if you want
240 users to be able to send mail.
241 %defattr(-,root,root)
242 %files pop3
243 /usr/local/citadel/modules/libpop3.so
244 /usr/local/citadel/modules/libpop3.la
245