]> code.citadel.org Git - citadel.git/blob - citadel/citadel.spec
* citadel.spec: updated for post-6.01
[citadel.git] / citadel / citadel.spec
1 # $Id$
2 Summary: Citadel/UX, the flexible, powerful way to build online communities
3 Name: citadel
4 Version: 6.01a
5 Release: 1
6 Copyright: GPL
7 Group: Applications/Communications
8 Source0: http://uncensored.citadel.org/pub/citadel/citadel-ux-%{PACKAGE_VERSION}.tar.gz
9 Buildroot: /var/tmp/citadel-%{PACKAGE_VERSION}-root
10 Icon: citux-64x64.xpm
11 Vendor: Citadel/UX Development Team
12 URL:  http://uncensored.citadel.org/citadel/
13 #Autoprov: false
14 ExcludeOS: hpux
15
16 %description
17 An advanced messaging system which can be used for BBS, groupware, and
18 online community applications.  It is multithreaded, client/server, database
19 driven, and accessible via a growing selection of front ends.
20
21 %prep
22 %setup -n citadel
23
24 %build
25 CFLAGS="$RPM_OPT_FLAGS" ./configure --with-pam
26 make
27
28 %install
29 rm -rf $RPM_BUILD_ROOT
30 mkdir -p $RPM_BUILD_ROOT/etc/pam.d
31 make root=$RPM_BUILD_ROOT install
32 touch $RPM_BUILD_ROOT/usr/local/citadel/.hushlogin
33
34 %clean
35 rm -rf "$RPM_BUILD_ROOT"
36
37 %package server
38 Summary: Citadel/UX, the flexible, powerful way to build online communities
39 Group: System Environment/Daemons
40 Requires: citadel-data
41 Obsoletes: citadel
42 Obsoletes: citadel-ux
43 %description server
44 Citadel/UX is an advanced messaging system which can be used for BBS,
45 groupware, and online community applications.  It is multithreaded,
46 client/server, database driven, and accessible via a growing selection of
47 front ends.  Remember to run /usr/local/citadel/setup after installing or
48 upgrading this package.
49 %defattr(-,root,root)
50 %files server
51 /etc/pam.d/citadel
52 %doc docs/chat.txt
53 %doc docs/citadel-with-berkeley-db.txt
54 %doc docs/COPYING.txt
55 %doc docs/copyright.txt
56 %doc docs/import-export.txt
57 %doc docs/inetsiteconfig.txt
58 %doc docs/mailinglists.txt
59 %doc docs/room-sharing-howto.txt
60 %doc docs/siteconfig.txt
61 %doc docs/sysop.txt
62 %doc docs/upgrading.txt
63 %doc docs/utils.txt
64 %dir /usr/local/citadel/bio
65 %dir /usr/local/citadel/bitbucket
66 %dir /usr/local/citadel/files
67 %dir /usr/local/citadel/images
68 %dir /usr/local/citadel/info
69 %dir /usr/local/citadel/userpics
70 /usr/local/citadel/aidepost
71 /usr/local/citadel/base64
72 %attr(4755,root,root) /usr/local/citadel/chkpwd
73 /usr/local/citadel/citmail
74 /usr/local/citadel/citserver
75 /usr/local/citadel/libcitserver.so
76 /usr/local/citadel/libcitserver.la
77 /usr/local/citadel/migratenet
78 /usr/local/citadel/msgform
79 /usr/local/citadel/readlog
80 /usr/local/citadel/sendcommand
81 /usr/local/citadel/setup
82 /usr/local/citadel/stats
83 /usr/local/citadel/userlist
84 /usr/local/citadel/utilsmenu
85 /usr/local/citadel/weekly
86 /usr/local/citadel/modules/libbio.so
87 /usr/local/citadel/modules/libbio.la
88 /usr/local/citadel/modules/libchat.so
89 /usr/local/citadel/modules/libchat.la
90 /usr/local/citadel/modules/libexpire.so
91 /usr/local/citadel/modules/libexpire.la
92 /usr/local/citadel/modules/libinetcfg.so
93 /usr/local/citadel/modules/libinetcfg.la
94 /usr/local/citadel/modules/liblistsub.so
95 /usr/local/citadel/modules/liblistsub.la
96 /usr/local/citadel/modules/libnetfilter.so
97 /usr/local/citadel/modules/libnetfilter.la
98 /usr/local/citadel/modules/libnetwork.so
99 /usr/local/citadel/modules/libnetwork.la
100 /usr/local/citadel/modules/libpas2.so
101 /usr/local/citadel/modules/libpas2.la
102 /usr/local/citadel/modules/librwho.so
103 /usr/local/citadel/modules/librwho.la
104 /usr/local/citadel/modules/libspam.so
105 /usr/local/citadel/modules/libspam.la
106 /usr/local/citadel/modules/libupgrade.so
107 /usr/local/citadel/modules/libupgrade.la
108 /usr/local/citadel/modules/libvandelay.so
109 /usr/local/citadel/modules/libvandelay.la
110 /usr/local/citadel/modules/libvcard.so
111 /usr/local/citadel/modules/libvcard.la
112 %pre server
113 # Add the "bbs" user
114 /usr/sbin/useradd -c "Citadel" -s /bin/false -r -d /usr/local/citadel \
115                 citadel 2> /dev/null || :
116 %post server
117 if [ -f /etc/inittab ]; then
118         if ! grep 'citserver' /etc/inittab > /dev/null; then
119                 echo "c1:2345:/usr/local/citadel/citserver -h/usr/local/citadel -t/usr/local/citadel/citserver.trace" >> /etc/inittab
120         fi
121 fi
122 if [ -f /etc/services ]; then
123         if ! grep '^citadel' /etc/services > /dev/null; then
124                 echo "citadel           504/tcp         # citadel" >> /etc/services
125         fi
126 fi
127 /sbin/ldconfig -n /usr/local/citadel /usr/local/citadel/modules
128 cd /usr/local/citadel
129 /usr/local/citadel/setup -q
130 %postun server
131 if [ -f /etc/inittab ]; then
132         grep -v 'citserver' < /etc/inittab > /etc/inittab.new && \
133         mv -f /etc/inittab.new /etc/inittab
134         /sbin/init q
135 fi
136
137 %package data
138 Summary: Data files for the Citadel/UX messaging system.
139 Group: System Environment/Daemons
140 %description data
141 Default data files for the Citadel/UX messaging system.  These files are
142 required by the Citadel/UX server.
143 %defattr(-,root,root)
144 %files data
145 /usr/local/citadel/.hushlogin
146 #%dir /usr/local/citadel/netconfigs
147 %dir /usr/local/citadel/network
148 %dir /usr/local/citadel/network/spoolin
149 %dir /usr/local/citadel/network/spoolout
150 %dir /usr/local/citadel/network/systems
151 %config(noreplace) /usr/local/citadel/network/filterlist
152 %config(noreplace) /usr/local/citadel/network/mail.aliases
153 %config(noreplace) /usr/local/citadel/network/mailinglists
154 %config(noreplace) /usr/local/citadel/network/rnews.xref
155 %config(noreplace) /usr/local/citadel/public_clients
156 %config /usr/local/citadel/help/aide
157 %config /usr/local/citadel/help/software
158 %config /usr/local/citadel/help/floors
159 %config(noreplace) /usr/local/citadel/help/hours
160 %config /usr/local/citadel/help/intro
161 %config /usr/local/citadel/help/mail
162 %config /usr/local/citadel/help/network
163 %config /usr/local/citadel/help/nice
164 %config(noreplace) /usr/local/citadel/help/policy
165 %config /usr/local/citadel/help/summary
166 %config(noreplace) /usr/local/citadel/messages/changepw
167 %config /usr/local/citadel/messages/aideopt
168 %config(noreplace) /usr/local/citadel/messages/entermsg
169 %config /usr/local/citadel/messages/dotopt
170 %config /usr/local/citadel/messages/mainmenu
171 %config /usr/local/citadel/messages/entopt
172 %config(noreplace) /usr/local/citadel/messages/goodbye
173 %config(noreplace) /usr/local/citadel/messages/hello
174 %config /usr/local/citadel/messages/help
175 %config(noreplace) /usr/local/citadel/messages/register
176 %config(noreplace) /usr/local/citadel/messages/newuser
177 %config /usr/local/citadel/messages/readopt
178 %config(noreplace) /usr/local/citadel/messages/roomaccess
179 %config(noreplace) /usr/local/citadel/messages/unlisted
180 %post data
181 # Yes, this is supposed to be executed twice; as ? might not yet exist
182 # but we want it to be listed.  It's kludgey; sue me.
183 ls /usr/local/citadel/help > "/usr/local/citadel/help/?"
184 ls /usr/local/citadel/help > "/usr/local/citadel/help/?"
185
186 %package client
187 Summary: Client for the Citadel/UX messaging system
188 Group: Applications/Communications
189 %description client
190 This is the text client software for the Citadel/UX messaging system.
191 Install this software if you need to connect to a Citadel/UX server.
192 %defattr(-,root,root)
193 %files client
194 /usr/local/citadel/citadel
195 /usr/local/citadel/citadel.rc
196 %doc docs/chat.txt
197 %post client
198 if [ -f /etc/services ]; then
199         if ! grep '^citadel' /etc/services > /dev/null; then
200                 echo "citadel           504/tcp         # citadel" >> /etc/services
201         fi
202 fi
203
204 %package smtp
205 Summary: SMTP server for the Citadel/UX messaging system
206 Group: System Environment/Daemons
207 Requires: citadel-server
208 %description smtp
209 This package provides the Citadel/UX SMTP service, which provides inbound
210 and outbound SMTP service for the Citadel/UX messaging system.  Install this
211 package if your Citadel/UX users should be able to send and receive Internet
212 e-mail.  If you also run another SMTP server you will need to read
213 docs/inetmailsetupmx.txt to configure SMTP service.
214 %defattr(-,root,root)
215 %files smtp
216 /usr/local/citadel/modules/libsmtp.so
217 /usr/local/citadel/modules/libsmtp.la
218 %doc docs/inetmailsetupmx.txt
219 %doc docs/inetmailsetup.txt
220
221 %package imap
222 Summary: IMAP server for the Citadel/UX messaging system
223 Group: System Environment/Daemons
224 Requires: citadel-server
225 %description imap
226 This package provides the Citadel/UX IMAP service, which provides IMAP
227 connectivity.  Install this package if you want to connect to the Citadel/UX
228 server with IMAP clients such as Outlook Express or Netscape.  Using this
229 access method, users can access both e-mail and all public rooms on the server.
230 %defattr(-,root,root)
231 %files imap
232 /usr/local/citadel/modules/libimap.so
233 /usr/local/citadel/modules/libimap.la
234
235 %package pop3
236 Summary: POP3 server for the Citadel/UX messaging system
237 Group: System Environment/Daemons
238 Requires: citadel-server
239 %description pop3
240 This package provides the Citadel/UX POP3 service, which provides POP3
241 connectivity.  Install this package if you want to connect to the Citadel/UX
242 server with POP3 clients such as Outlook Express or Netscape.  Note that the
243 POP3 client can only receive mail; install citadel-smtp as well if you want
244 users to be able to send mail.
245 %defattr(-,root,root)
246 %files pop3
247 /usr/local/citadel/modules/libpop3.so
248 /usr/local/citadel/modules/libpop3.la
249
250 %package mrtg
251 Summary: Export Citadel/UX statistics to MRTG
252 Group: System Environment/Daemons
253 Requires: citadel-server
254 Requires: mrtg
255 %description mrtg
256 This package allows Citadel/UX to export server statistics in a format
257 compatible with the Multi Router Traffic Grapher.
258 %files mrtg
259 /usr/local/citadel/modules/libmrtg.so
260 /usr/local/citadel/modules/libmrtg.la
261
262 %package calendar
263 Summary: Citadel/UX calendaring and scheduling services
264 Group: System Environment/Daemons
265 Requires: citadel-server
266 Requires: libical.so
267 %description calendar
268 This package provides calendaring and scheduling services for Citadel/UX.
269 It will interoperate with other calendaring packages that support the Internet
270 standard vCalendar formats.  Currently only meeting scheduling is supported.
271 (This is an experimental package!)
272 %files calendar
273 /usr/local/citadel/modules/libcalendar.so
274 /usr/local/citadel/modules/libcalendar.la
275