]> code.citadel.org Git - citadel.git/blobdiff - citadel/citadel.spec
* Replaced all "Citadel/UX" references with "Citadel"
[citadel.git] / citadel / citadel.spec
index fc90c13a4de1de92bb59a713df0f4740dca10697..3613d8189384f4e85d3a1bcafea41fa9f2a6d2ce 100644 (file)
@@ -1,15 +1,45 @@
 # $Id$
-Summary: Citadel/UX, the flexible, powerful way to build online communities
+Summary: Citadel, the flexible, powerful way to build online communities
 Name: citadel
-Version: 6.20
+Version: 6.24
 Release: 1
 Copyright: GPL
 Group: Applications/Communications
-Source0: http://uncensored.citadel.org/pub/citadel/citadel-ux-%{PACKAGE_VERSION}.tar.gz
+Source0: http://my.citadel.org/download/citadel-ux-%{PACKAGE_VERSION}.tar.gz
 Buildroot: /var/tmp/citadel-%{PACKAGE_VERSION}-root
-Icon: citux-64x64.xpm
-Vendor: Citadel/UX Development Team
+#Icon: citux-64x64.xpm
+Vendor: Citadel Development Team
 URL:  http://uncensored.citadel.org/citadel/
+
+# I don't think we should actually Require this because we can be configured
+# not to connect to an LDAP server. So we really only require the client
+# libraries, and the runtime dependency on that is detected automatically by
+# RPM.
+#Requires: openldap-servers
+
+# Note some of these BuildRequire's are Linux specific and possibly even
+# distribution specific, but I am adding them FOR NOW just to document the
+# dependencies and make it more likely that everyone is building identical
+# packages.
+BuildRequires: gcc
+BuildRequires: bison
+BuildRequires: glibc-devel
+BuildRequires: openldap-devel
+BuildRequires: db4-devel >= 4.1
+BuildRequires: pam-devel
+
+# Newt is not supported by redhat for binary compatibility with future
+# distributions, so we've disabled it.
+#BuildRequires: newt-devel
+
+BuildRequires: openssl-devel
+BuildRequires: ncurses-devel
+BuildRequires: zlib-devel
+
+# debuginfo packages don't get built unless this packages is installed:
+# NB: We do not DISTRIBUTE the debuginfo packages - error
+BuildRequires: redhat-rpm-config
+
 #Autoprov: false
 ExcludeOS: hpux
 
@@ -22,7 +52,7 @@ driven, and accessible via a growing selection of front ends.
 %setup -n citadel
 
 %build
-CFLAGS="$RPM_OPT_FLAGS" ./configure --with-pam
+CFLAGS="$RPM_OPT_FLAGS" ./configure --with-pam --enable-autologin --with-ldap --without-newt --with-libical
 make
 
 %install
@@ -30,12 +60,17 @@ rm -rf $RPM_BUILD_ROOT
 mkdir -p $RPM_BUILD_ROOT/etc/pam.d
 make root=$RPM_BUILD_ROOT install
 touch $RPM_BUILD_ROOT/usr/local/citadel/.hushlogin
+# Things that shouldn't be "installed" but were anyway
+rm -f $RPM_BUILD_ROOT/"/usr/local/citadel/help/?"
+rm -f $RPM_BUILD_ROOT/usr/local/citadel/README.txt
+rm -rf $RPM_BUILD_ROOT/usr/local/citadel/docs
+rm -rf $RPM_BUILD_ROOT/usr/local/citadel/techdoc
 
 %clean
 rm -rf "$RPM_BUILD_ROOT"
 
 %package server
-Summary: Citadel/UX, the flexible, powerful way to build online communities
+Summary: Citadel, the flexible, powerful way to build online communities
 Group: System Environment/Daemons
 Requires: citadel-data
 Obsoletes: citadel
@@ -46,15 +81,16 @@ Obsoletes: citadel-imap
 Obsoletes: citadel-mrtg
 Obsoletes: citadel-calendar
 %description server
-Citadel/UX is an advanced messaging system which can be used for BBS,
-groupware, and online community applications.  It is multithreaded,
+Citadel is an advanced messaging system which can be used for BBS, email,
+groupware and online community applications.  It is multithreaded,
 client/server, database driven, and accessible via a growing selection of
-front ends.  Remember to run /usr/local/citadel/setup after installing or
-upgrading this package.
+front ends.
 %defattr(-,root,root)
 %files server
 /etc/pam.d/citadel
-%doc docs/citadel.html
+%doc docs/*
+%doc techdoc
+%doc README.txt
 %dir /usr/local/citadel/bio
 %dir /usr/local/citadel/bitbucket
 %dir /usr/local/citadel/files
@@ -69,7 +105,6 @@ upgrading this package.
 /usr/local/citadel/msgform
 /usr/local/citadel/sendcommand
 /usr/local/citadel/setup
-/usr/local/citadel/stats
 /usr/local/citadel/stress
 /usr/local/citadel/userlist
 /usr/local/citadel/utilsmenu
@@ -80,7 +115,7 @@ upgrading this package.
 %post server
 if [ -f /etc/inittab ]; then
        if ! grep 'citserver' /etc/inittab > /dev/null; then
-               echo "c1:2345:/usr/local/citadel/citserver -h/usr/local/citadel -x7 -llocal4" >> /etc/inittab
+               echo "c1:2345:respawn:/usr/local/citadel/citserver -h/usr/local/citadel -x7 -llocal4" >> /etc/inittab
        fi
 fi
 if [ -f /etc/services ]; then
@@ -98,11 +133,11 @@ if [ -f /etc/inittab ]; then
 fi
 
 %package data
-Summary: Data files for the Citadel/UX messaging system.
+Summary: Data files for the Citadel messaging system.
 Group: System Environment/Daemons
 %description data
-Default data files for the Citadel/UX messaging system.  These files are
-required by the Citadel/UX server.
+Default data files for the Citadel messaging system.  These files are
+required by the Citadel server.
 %defattr(-,root,root)
 %files data
 /usr/local/citadel/.hushlogin
@@ -111,10 +146,7 @@ required by the Citadel/UX server.
 %dir /usr/local/citadel/network/spoolin
 %dir /usr/local/citadel/network/spoolout
 %dir /usr/local/citadel/network/systems
-%config(noreplace) /usr/local/citadel/network/filterlist
 %config(noreplace) /usr/local/citadel/network/mail.aliases
-%config(noreplace) /usr/local/citadel/network/mailinglists
-%config(noreplace) /usr/local/citadel/network/rnews.xref
 %config(noreplace) /usr/local/citadel/public_clients
 %config /usr/local/citadel/help/aide
 %config /usr/local/citadel/help/software
@@ -147,11 +179,11 @@ required by the Citadel/UX server.
 /bin/ls /usr/local/citadel/help > "/usr/local/citadel/help/?"
 
 %package client
-Summary: Client for the Citadel/UX messaging system
+Summary: Client for the Citadel messaging system
 Group: Applications/Communications
 %description client
-This is the text client software for the Citadel/UX messaging system.
-Install this software if you need to connect to a Citadel/UX server.
+This is the text client software for the Citadel messaging system.
+Install this software if you need to connect to a Citadel server.
 %defattr(-,root,root)
 %files client
 /usr/local/citadel/citadel