]> code.citadel.org Git - citadel.git/blobdiff - citadel/debian/rules
* added a.n.o patches for solaris compatibility
[citadel.git] / citadel / debian / rules
index 1d15f6e169190ef03c090c9998e1deccf4c6f0ad..1eb7dac98ec0881c737a0aa5d2f7b6c7d929140c 100755 (executable)
@@ -1,35 +1,61 @@
 #!/usr/bin/make -f
-# -*- makefile -*-
+
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
 # This has to be exported to make some magic below work.
+DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
 export DH_OPTIONS
+
 DEB_DESTDIR = $(CURDIR)/debian/tmp
+
 CFLAGS = -Wall -g
 
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0 -ggdb
+
+EXTRA_ARGS=
+PROFILE_ARGS=
+#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling threadoff"
+ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
+       PROFILE_ARGS= --with-gprof
+endif
+ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -O0 -ggdb -rdynamic -D_GNU_SOURCE -MD -MP -D TECH_PREVIEW
+       LDFLAGS+=-Wl,--no-undefined -Wl,--as-needed
+       EXTRA_ARGS = --with-backtrace
 else
+       LDFLAGS+=-Wl,--no-undefined -Wl,--as-needed
        CFLAGS += -O2
 endif
 
+ifneq (,$(findstring threadoff,$(DEB_BUILD_OPTIONS)))
+       THREAD_ARGS=--without-threaded-client
+else
+       THREAD_ARGS=
+endif
+
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       CFLAGS="$(CFLAGS)" ./configure \
-               --prefix=/usr/sbin \
+
+       LDFLAGS="$(LDFLAGS)"; CFLAGS="$(CFLAGS)" ./configure \
+               --with-prefix=/var/lib/citadel \
                --with-datadir=/var/lib/citadel \
+               --with-staticdatadir=/usr/share/citadel-server \
                --with-spooldir=/var/spool/citadel \
                --with-sysconfdir=/etc/citadel \
                --with-rundir=/var/run/citadel \
                --with-docdir=/usr/share/doc/citadel-doc/ \
+               --with-ssldir=/etc/ssl/citadel/ \
+               --with-utility-bindir=/usr/lib/citadel-server/ \
                --with-pam \
                --with-db \
                --with-zlib \
                --with-ldap \
                --with-libical \
-               --with-libsieve
+               --with-libsieve \
+               --enable-debug $(EXTRA_ARGS) $(PROFILE_ARGS) $(THREAD_ARGS)
 
        touch configure-stamp
 
@@ -44,15 +70,18 @@ build-arch-stamp: configure-stamp
 
 build-indep: build-indep-stamp
 build-indep-stamp: configure-stamp
+
        touch $@
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-arch-stamp build-indep-stamp #CONFIGURE-STAMP#
-       -$(MAKE) distclean
+       rm -f build-arch-stamp build-indep-stamp configure-stamp
+
+       [ ! -f Makefile ] || $(MAKE) distclean
 
        dh_clean 
+       rm -f config.status config.log
 
 install: install-indep install-arch
 install-indep:
@@ -60,7 +89,9 @@ install-indep:
        dh_testroot
        dh_clean -k -i 
        dh_installdirs -i
+
        $(MAKE) DESTDIR=$(DEB_DESTDIR) install-doc-new
+
        dh_install -i --sourcedir=debian/tmp
 
 install-arch:
@@ -68,20 +99,19 @@ install-arch:
        dh_testroot
        dh_clean -k -s 
        dh_installdirs -s
+
        $(MAKE) DESTDIR=$(DEB_DESTDIR) install-exec-new install-data-new
 
+       install -D -p -m0755 database_cleanup.sh \
+               $(DEB_DESTDIR)/usr/share/doc/citadel-server/examples/database_cleanup.sh
 
-       mkdir -p $(DEB_DESTDIR)/usr/lib/citadel-server
-       mv $(DEB_DESTDIR)/usr/sbin/setup \
-          $(DEB_DESTDIR)/usr/lib/citadel-server/
-       cp $(DEB_DESTDIR)/usr/sbin/citmail \
-          $(DEB_DESTDIR)/usr/sbin/sendmail
+       install -D -p -m0644 docs/welcomemail.html \
+               $(DEB_DESTDIR)/usr/share/doc/citadel-server/welcomemail.html
 
-       mkdir -p $(DEB_DESTDIR)/usr/share/doc/citadel-server/
-        mv $(DEB_DESTDIR)/usr/share/doc/citadel-doc/database_cleanup.sh \
-                $(DEB_DESTDIR)/usr/share/doc/citadel-server/
+       install -D -p -m0644 docs/welcomemail.txt \
+               $(DEB_DESTDIR)/usr/share/doc/citadel-server/welcomemail.txt
 
-        dh_install -s --sourcedir=debian/tmp
+       dh_install -s --sourcedir=debian/tmp
 
 binary-common:
        dh_testdir