]> code.citadel.org Git - citadel.git/blobdiff - citadel/debian/rules
* added a.n.o patches for solaris compatibility
[citadel.git] / citadel / debian / rules
index c0ca8031ced686c11f5ed43d536e1bc607eec81e..1eb7dac98ec0881c737a0aa5d2f7b6c7d929140c 100755 (executable)
@@ -4,6 +4,9 @@
 #export DH_VERBOSE=1
 
 # This has to be exported to make some magic below work.
+DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
 export DH_OPTIONS
 
 DEB_DESTDIR = $(CURDIR)/debian/tmp
@@ -13,22 +16,30 @@ CFLAGS = -Wall -g
 
 EXTRA_ARGS=
 PROFILE_ARGS=
-#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling"
+#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling threadoff"
 ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
        PROFILE_ARGS= --with-gprof
 endif
 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0 -ggdb -rdynamic -D_GNU_SOURCE -MD -MP 
+       CFLAGS += -O0 -ggdb -rdynamic -D_GNU_SOURCE -MD -MP -D TECH_PREVIEW
+       LDFLAGS+=-Wl,--no-undefined -Wl,--as-needed
        EXTRA_ARGS = --with-backtrace
 else
+       LDFLAGS+=-Wl,--no-undefined -Wl,--as-needed
        CFLAGS += -O2
 endif
 
+ifneq (,$(findstring threadoff,$(DEB_BUILD_OPTIONS)))
+       THREAD_ARGS=--without-threaded-client
+else
+       THREAD_ARGS=
+endif
+
 configure: configure-stamp
 configure-stamp:
        dh_testdir
 
-       CFLAGS="$(CFLAGS)" ./configure \
+       LDFLAGS="$(LDFLAGS)"; CFLAGS="$(CFLAGS)" ./configure \
                --with-prefix=/var/lib/citadel \
                --with-datadir=/var/lib/citadel \
                --with-staticdatadir=/usr/share/citadel-server \
@@ -44,7 +55,7 @@ configure-stamp:
                --with-ldap \
                --with-libical \
                --with-libsieve \
-               --enable-debug $(EXTRA_ARGS) $(PROFILE_ARGS)
+               --enable-debug $(EXTRA_ARGS) $(PROFILE_ARGS) $(THREAD_ARGS)
 
        touch configure-stamp
 
@@ -67,7 +78,7 @@ clean:
        dh_testroot
        rm -f build-arch-stamp build-indep-stamp configure-stamp
 
-       -$(MAKE) distclean
+       [ ! -f Makefile ] || $(MAKE) distclean
 
        dh_clean 
        rm -f config.status config.log