]> code.citadel.org Git - citadel.git/blobdiff - citadel/debian/rules
work on sixel support
[citadel.git] / citadel / debian / rules
diff --git a/citadel/debian/rules b/citadel/debian/rules
deleted file mode 100755 (executable)
index 9015d45..0000000
+++ /dev/null
@@ -1,150 +0,0 @@
-#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-#
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-#
-# Modified to make a template file for a multi-binary package with separated
-# build-arch and build-indep targets  by Bill Allombert 2001
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-# This has to be exported to make some magic below work.
-export DH_OPTIONS
-
-# These are used for cross-compiling and for saving the configure script
-# from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-export VERSION=`grep 'THIS IS' $(CURDIR)/ChangeLog  |head -n 1 |sed "s;.* ;;"`
-
-CFLAGS = -Wall -g
-
-#ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0 -ggdb
-#else
-#      CFLAGS += -O2
-#endif
-
-config.status: configure
-       dh_testdir
-       CFLAGS="$(CFLAGS)" ./configure \
-               --host=$(DEB_HOST_GNU_TYPE) \
-               --build=$(DEB_BUILD_GNU_TYPE) \
-               --prefix=/usr/sbin \
-               --with-sysconfdir=/etc/citadel \
-               --with-spooldir=/var/spool/citadel \
-               --with-datadir=/var/lib/citadel \
-               --with-rundir=/var/run/citadel \
-               --with-docdir=/usr/share/doc/citadel-doc/ \
-               --enable-autologin --with-pam \
-               --with-ical --with-db --with-ldap
-
-
-#Architecture 
-build: build-arch build-indep
-
-build-arch: build-arch-stamp
-build-arch-stamp:  config.status
-
-       # Add here commands to compile the arch part of the package.
-       #$(MAKE) 
-       touch build-arch-stamp
-
-build-indep: build-indep-stamp
-build-indep-stamp:  config.status
-
-       # Add here commands to compile the indep part of the package.
-       #$(MAKE) doc
-       touch build-indep-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-arch-stamp build-indep-stamp #CONFIGURE-STAMP#
-       -$(MAKE) distclean
-ifneq "$(wildcard /usr/share/misc/config.sub)" ""
-       cp -f /usr/share/misc/config.sub config.sub
-endif
-ifneq "$(wildcard /usr/share/misc/config.guess)" ""
-       cp -f /usr/share/misc/config.guess config.guess
-endif
-
-
-       dh_clean 
-
-install: install-indep install-arch
-install-indep:
-       dh_testdir
-       dh_testroot
-       dh_clean -k -i 
-       dh_installdirs -i
-       export root=$(CURDIR)/debian/tmp; $(MAKE) install-doc-new prefix=$(CURDIR)/debian/citadel-doc/
-
-
-install-arch:
-       dh_testdir
-       dh_testroot
-       dh_clean -k -s 
-       dh_installdirs -s
-       mkdir -p  $(CURDIR)/debian/tmp/
-       export root=$(CURDIR)/debian/tmp/;$(MAKE) install-exec-new install-data-new
-
-       mkdir -p $(CURDIR)/debian/tmp/usr/lib/citadel-server
-       mv \
-               $(CURDIR)/debian/tmp/usr/sbin/setup \
-               $(CURDIR)/debian/tmp/usr/lib/citadel-server/
-#      cd $(CURDIR)/debian/tmp/usr/share/doc/citadel-server/examples/help; md5sum * >../help.md5sums
-#      cd $(CURDIR)/debian/tmp/usr/share/doc/citadel-server/examples/messages; md5sum * >../messages.md5sums
-       cp \
-               $(CURDIR)/debian/tmp/usr/sbin/citmail \
-               $(CURDIR)/debian/tmp/usr/sbin/sendmail
-       dh_installexamples  
-       dh_install 
-# Must not depend on anything. This is to be called by
-# binary-arch/binary-indep
-# in another 'make' thread.
-binary-common:
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs ChangeLog
-       dh_installdocs
-       dh_installexamples
-#      dh_installmenu
-       dh_installdebconf       
-#      dh_installlogrotate     
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-       dh_installinit  --name=citadel
-#      dh_installcron
-#      dh_installinfo
-       dh_installman
-#doesn't work like that. will be done by postinst.
-#      mkdir -p $(CURDIR)/debian/citadel-mta/usr/sbin
-#      dh_link --package=citadel-mta /usr/sbin/citmail /usr/sbin/sendmail
-       dh_strip
-       dh_compress 
-       dh_fixperms
-#      dh_perl
-#      dh_python
-       dh_makeshlibs
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-# Build architecture independant packages using the common target.
-binary-indep: build-indep install-indep
-       $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
-
-# Build architecture dependant packages using the common target.
-binary-arch: build-arch install-arch
-       $(MAKE) -f debian/rules DH_OPTIONS=-a binary-common
-
-binary: binary-arch binary-indep
-.PHONY: build clean binary-indep binary-arch binary install install-indep install-arch