]> code.citadel.org Git - citadel.git/blobdiff - citadel/debian/rules
Libevent integration
[citadel.git] / citadel / debian / rules
index 6779c8f512e592f4acd54e0959b1cb67ed3d1ded..5c51eb473f202bc1d74720eb58abf7b9790ba5f9 100755 (executable)
@@ -16,7 +16,7 @@ CFLAGS = -Wall -g
 
 EXTRA_ARGS=
 PROFILE_ARGS=
-#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling threadoff rss"
+#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling threadoff rss gcov"
 ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
        PROFILE_ARGS= --with-gprof
 endif
@@ -24,6 +24,9 @@ ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0 -ggdb -rdynamic -D_GNU_SOURCE -MD -MP -D TECH_PREVIEW
        LDFLAGS+=-Wl,--no-undefined -Wl,--as-needed
        EXTRA_ARGS = --with-backtrace
+       ifneq (,$(findstring event,$(DEB_BUILD_OPTIONS)))
+               EXTRA_ARGS = --with-backtrace --with-experimental_eventsmtp
+       endif
 else
        LDFLAGS+=-Wl,--no-undefined -Wl,--as-needed
        CFLAGS += -O2
@@ -45,6 +48,11 @@ ifneq (,$(findstring iodbg,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -D BIGBAD_IODBG
 endif
 
+ifneq (,$(findstring gcov,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -fprofile-arcs -ftest-coverage
+       LDFLAGS += -fprofile-arcs -ftest-coverage
+endif
+
 configure: configure-stamp
 configure-stamp:
        dh_testdir