]> code.citadel.org Git - citadel.git/blobdiff - citadel/debian/rules
Libevent integration
[citadel.git] / citadel / debian / rules
index c9b87e558f686c3a01ccc02902daa85f5bdaf342..5c51eb473f202bc1d74720eb58abf7b9790ba5f9 100755 (executable)
@@ -16,7 +16,7 @@ CFLAGS = -Wall -g
 
 EXTRA_ARGS=
 PROFILE_ARGS=
-#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling threadoff"
+#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling threadoff rss gcov"
 ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
        PROFILE_ARGS= --with-gprof
 endif
@@ -24,6 +24,9 @@ ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0 -ggdb -rdynamic -D_GNU_SOURCE -MD -MP -D TECH_PREVIEW
        LDFLAGS+=-Wl,--no-undefined -Wl,--as-needed
        EXTRA_ARGS = --with-backtrace
+       ifneq (,$(findstring event,$(DEB_BUILD_OPTIONS)))
+               EXTRA_ARGS = --with-backtrace --with-experimental_eventsmtp
+       endif
 else
        LDFLAGS+=-Wl,--no-undefined -Wl,--as-needed
        CFLAGS += -O2
@@ -31,10 +34,25 @@ endif
 
 ifneq (,$(findstring threadoff,$(DEB_BUILD_OPTIONS)))
        THREAD_ARGS=--without-threaded-client
+       CFLAGS += -D WITH_THREADLOG
 else
        THREAD_ARGS=
 endif
 
+
+ifneq (,$(findstring rss,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -D DEBUG_RSS
+endif
+
+ifneq (,$(findstring iodbg,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -D BIGBAD_IODBG
+endif
+
+ifneq (,$(findstring gcov,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -fprofile-arcs -ftest-coverage
+       LDFLAGS += -fprofile-arcs -ftest-coverage
+endif
+
 configure: configure-stamp
 configure-stamp:
        dh_testdir
@@ -51,6 +69,7 @@ configure-stamp:
                --with-ssldir=/etc/ssl/citadel/ \
                --with-utility-bindir=/usr/lib/citadel-server/ \
                --with-autosysconfdir=/var/lib/citadel/data/ \
+                --with-localedir=/usr/share/ \
                --with-pam \
                --with-db \
                --enable-debug $(EXTRA_ARGS) $(PROFILE_ARGS) $(THREAD_ARGS)
@@ -76,10 +95,10 @@ clean:
        dh_testroot
        rm -f build-arch-stamp build-indep-stamp configure-stamp
 
-       [ ! -f Makefile ] || $(MAKE) distclean
 
        dh_clean 
        rm -f config.status config.log
+#[ ! -f Makefile ] || $(MAKE) distclean
 
 install: install-indep install-arch
 install-indep: build-indep
@@ -98,6 +117,7 @@ install-arch: build-arch
        dh_clean -k -s 
        dh_installdirs -s
 
+       $(MAKE) install-locale DESTDIR=$(DEB_DESTDIR)
        $(MAKE) DESTDIR=$(DEB_DESTDIR) install-exec-new install-data-new
 
        install -D -p -m0755 database_cleanup.sh \