]> code.citadel.org Git - citadel.git/blobdiff - citadel/debian/rules
Add some more debugging to the session destroyer; -> backtrace.
[citadel.git] / citadel / debian / rules
index a28907b67351e99aa685a5b077be315ffb79e4b7..85489575c077f88c549fd83a25edcea05b6816db 100755 (executable)
@@ -23,6 +23,7 @@ endif
 ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
        PROFILE_ARGS= --with-gprof
 endif
+
 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0 -ggdb -rdynamic -D_GNU_SOURCE -MD -MP -D TECH_PREVIEW
        LDFLAGS+=-Wl,--no-undefined -Wl,--as-needed
@@ -35,6 +36,12 @@ else
        CFLAGS += -O2
 endif
 
+ifneq (,$(findstring backtrace,$(DEB_BUILD_OPTIONS)))
+       CFLAGS+= -rdynamic -D_GNU_SOURCE -MD -MP
+       LDFLAGS+=-Wl,--no-undefined -Wl,--as-needed
+       EXTRA_ARGS += --with-backtrace
+endif
+
 ifneq (,$(findstring threadoff,$(DEB_BUILD_OPTIONS)))
        THREAD_ARGS=--without-threaded-client
        CFLAGS += -D WITH_THREADLOG