]> code.citadel.org Git - citadel.git/blobdiff - citadel/debian/rules
* modified build script to find out the version the way we do it now.
[citadel.git] / citadel / debian / rules
index a1826e715214445cc2c9c5c68b7c0693379acaec..cec20b37bead5a6f13fceaaf63818081e17f5192 100755 (executable)
@@ -24,11 +24,11 @@ export VERSION=`grep 'THIS IS' $(CURDIR)/ChangeLog  |head -n 1 |sed "s;.* ;;"`
 
 CFLAGS = -Wall -g
 
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0
-else
-       CFLAGS += -O2
-endif
+#ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -O0 -ggdb
+#else
+#      CFLAGS += -O2
+#endif
 
 config.status: configure
        dh_testdir
@@ -41,6 +41,7 @@ config.status: configure
                --with-datadir=/var/lib/citadel \
                --with-rundir=/var/run/citadel \
                --with-docdir=/usr/share/doc/citadel-doc/ \
+               --enable-autologin --with-pam \
                --with-ical --with-db --with-ldap
 
 
@@ -97,6 +98,9 @@ install-arch:
        mv \
                $(CURDIR)/debian/tmp/usr/sbin/setup \
                $(CURDIR)/debian/tmp/usr/lib/citadel-server/
+       mv \
+               $(CURDIR)/debian/tmp/usr/sbin/ctdlsvc \
+               $(CURDIR)/debian/tmp/usr/lib/citadel-server/
 #      cd $(CURDIR)/debian/tmp/usr/share/doc/citadel-server/examples/help; md5sum * >../help.md5sums
 #      cd $(CURDIR)/debian/tmp/usr/share/doc/citadel-server/examples/messages; md5sum * >../messages.md5sums
        cp \
@@ -119,7 +123,7 @@ binary-common:
 #      dh_installemacsen
 #      dh_installpam
 #      dh_installmime
-#      dh_installinit
+       dh_installinit  --name=citadel
 #      dh_installcron
 #      dh_installinfo
        dh_installman