]> code.citadel.org Git - citadel.git/blobdiff - libcitadel/debian/rules
Remove preprocessor tests for OpenSSL. It's a requirement.
[citadel.git] / libcitadel / debian / rules
diff --git a/libcitadel/debian/rules b/libcitadel/debian/rules
deleted file mode 100755 (executable)
index 966239a..0000000
+++ /dev/null
@@ -1,88 +0,0 @@
-#!/usr/bin/make -f
-# -*- mode: makefile; coding: utf-8 -*-
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-  CFLAGS += -O0
-else
-  CFLAGS += -O2 -fno-strict-aliasing
-endif
-
-build: build-stamp
-build-stamp:
-       dh_testdir
-
-# ./configure
-       CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
-               --prefix=/usr
-
-# Build libcitadel
-       $(MAKE)
-
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp install*-stamp
-       [ ! -f Makefile ] || $(MAKE) distclean
-       dh_clean
-
-install: install-stamp
-install-stamp: build-stamp
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs
-
-       $(MAKE) DESTDIR=`pwd`/debian/tmp install
-
-       touch install-stamp
-
-# Build architecture-independent files here.
-binary-indep: build install
-       dh_testdir -i
-       dh_testroot -i
-       dh_installdocs -i -A README
-       dh_installchangelogs -i debian/no-upstream-changelog
-       dh_install -i --sourcedir=debian/tmp
-       dh_link -i
-       dh_strip -i
-       dh_compress -i
-       dh_fixperms -i
-       dh_installdeb -i
-       dh_shlibdeps -i
-       dh_gencontrol -i
-       dh_md5sums -i
-       dh_builddeb -i
-
-# Build architecture-dependent files here.
-binary-arch: build install
-       dh_testdir -a
-       dh_testroot -a
-#      dh_installdocs -plibcitadel1
-       dh_installchangelogs -plibcitadel
-       dh_install -a --sourcedir=debian/tmp
-       dh_link -a
-       dh_strip -a --dbg-package=libcitadel1-dbg
-       dh_compress -a
-       dh_fixperms -a
-       dh_makeshlibs -a -V 'libcitadel1'
-       dh_installdeb -a
-       dh_shlibdeps -a
-       dh_gencontrol -a
-       dh_md5sums -a
-       dh_builddeb -a
-
-source diff:                                                                  
-       @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install