]> code.citadel.org Git - citadel.git/blobdiff - libcitadel/debian/rules
(no commit message)
[citadel.git] / libcitadel / debian / rules
index 786c8dfb18be1ea2f77b0e1759a38845f838ab1d..2219e78da7edff126e830a3682d69d1d4fe30ecc 100755 (executable)
@@ -11,10 +11,10 @@ DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
 CFLAGS = -Wall -g
 
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-  CFLAGS += -O0
+ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -O0 -ggdb -rdynamic -MD -MP 
 else
-  CFLAGS += -O2 -fno-strict-aliasing
+       CFLAGS += -O2
 endif
 
 build: build-stamp
@@ -78,7 +78,7 @@ binary-arch: build install
        dh_strip -a --dbg-package=libcitadel1-dbg
        dh_compress -a
        dh_fixperms -a
-       dh_makeshlibs -a -V 'libcitadel'
+       dh_makeshlibs -a -V 'libcitadel1'
        dh_installdeb -a
        dh_shlibdeps -a
        dh_gencontrol -a