]> code.citadel.org Git - citadel.git/blobdiff - libcitadel/debian/rules
(no commit message)
[citadel.git] / libcitadel / debian / rules
index 966239a9541931baef420e3a27d15b34e5e5764f..2219e78da7edff126e830a3682d69d1d4fe30ecc 100755 (executable)
@@ -4,15 +4,17 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
+export DH_COMPAT = 5
+
 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
 CFLAGS = -Wall -g
 
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-  CFLAGS += -O0
+ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -O0 -ggdb -rdynamic -MD -MP 
 else
-  CFLAGS += -O2 -fno-strict-aliasing
+       CFLAGS += -O2
 endif
 
 build: build-stamp
@@ -32,7 +34,9 @@ clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp install*-stamp
-       [ ! -f Makefile ] || $(MAKE) distclean
+
+       -$(MAKE) distclean
+
        dh_clean
 
 install: install-stamp