]> code.citadel.org Git - citadel.git/blobdiff - libcitadel/debian/rules
* fixed several crash / invalid data cases in the hash implementation
[citadel.git] / libcitadel / debian / rules
index 786c8dfb18be1ea2f77b0e1759a38845f838ab1d..4ce1be12f96893ceb0886f0748acf5cd81bf24a8 100755 (executable)
@@ -11,10 +11,10 @@ DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
 CFLAGS = -Wall -g
 
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-  CFLAGS += -O0
+ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -O0 -ggdb -rdynamic -MD -MP 
 else
-  CFLAGS += -O2 -fno-strict-aliasing
+       CFLAGS += -O2
 endif
 
 build: build-stamp
@@ -56,16 +56,16 @@ binary-indep: build install
        dh_testroot -i
        dh_installdocs -i -A README
        dh_installchangelogs -i debian/no-upstream-changelog
-       dh_install -i --sourcedir=debian/tmp
-       dh_link -i
-       dh_strip -i
-       dh_compress -i
-       dh_fixperms -i
-       dh_installdeb -i
-       dh_shlibdeps -i
-       dh_gencontrol -i
-       dh_md5sums -i
-       dh_builddeb -i
+#      dh_install -i --sourcedir=debian/tmp
+#      dh_link -i
+#      dh_strip -i
+#      dh_compress -i
+#      dh_fixperms -i
+#      dh_installdeb -i
+#      dh_shlibdeps -i
+#      dh_gencontrol -i
+#      dh_md5sums -i
+#      dh_builddeb -i
 
 # Build architecture-dependent files here.
 binary-arch: build install
@@ -78,7 +78,7 @@ binary-arch: build install
        dh_strip -a --dbg-package=libcitadel1-dbg
        dh_compress -a
        dh_fixperms -a
-       dh_makeshlibs -a -V 'libcitadel'
+       dh_makeshlibs -a -V 'libcitadel1'
        dh_installdeb -a
        dh_shlibdeps -a
        dh_gencontrol -a