]> code.citadel.org Git - citadel.git/blobdiff - webcit/debian/rules
* added central location for tiny_mce
[citadel.git] / webcit / debian / rules
index 9ce903b6caa2acf5a05299286c504f121cc731dc..10d6d8fb74557ae5214ef61438a7c5b6d74a67d4 100755 (executable)
@@ -23,18 +23,19 @@ endif
 configure: configure-stamp
 configure-stamp:
        dh_testdir
+       rm -rf $(CURDIR)/debian/webcit $(CURDIR)/debian/citadel-webcit $(CURDIR)/debian/citadel-webcit-apache
        CFLAGS="$(CFLAGS)" ./configure \
                --host=$(DEB_HOST_GNU_TYPE) \
                --build=$(DEB_BUILD_GNU_TYPE) \
-               --prefix=/var/lib/citadel/www/ \
-               --with-sysconfdir=/etc/citadel \
-               --with-spooldir=/var/spool/citadel \
-               --with-datadir=/var/lib/citadel \
+               --prefix=/usr \
+               --with-staticdir=/usr/share/doc/citadel-webcit/examples \
+               --with-staticrundir=/var/lib/citadel/www/ \
+               --with-editordir=/usr/share/ \
                --with-rundir=/var/run/citadel \
                --with-ical --with-db --with-ldap --with-zlib --with-ssl --with-libiconf --with-newt --with-included-gettext
 
        touch configure-stamp
-
+#we don't do /usr/share/tiny_mce, because of make brings one with it.
 
 build: build-stamp
 
@@ -63,28 +64,15 @@ install: build
        dh_clean -k 
        dh_installdirs
 
-       # Add here commands to install the package into debian/webcit.
+# Add here commands to install the package into debian/webcit.
        root=$(CURDIR)/debian/webcit/
-       mkdir -p $(CURDIR)/debian/webcit/var/lib/citadel/www/
-       export root=$(CURDIR)/debian/webcit; $(MAKE) install DESTDIR=$(CURDIR)/debian/webcit/
-       mkdir -p $(CURDIR)/debian/citadel-webcit/usr/share/doc/citadel-webcit/examples
-       mkdir -p $(CURDIR)/debian/citadel-webcit/usr/share/doc/citadel-webcit/contrib
-       mkdir -p $(CURDIR)/debian/citadel-webcit/usr/sbin
-       mkdir -p $(CURDIR)/debian/citadel-webcit/usr/lib/citadel-webcit/
-       mv $(CURDIR)/debian/webcit/var/lib/citadel/www/static \
-               $(CURDIR)/debian/citadel-webcit/usr/share/doc/citadel-webcit/examples/
-       mv $(CURDIR)/debian/webcit/var/lib/citadel/www/tiny_mce \
-               $(CURDIR)/debian/citadel-webcit/usr/share/doc/citadel-webcit/examples/
-# TODO: locale -> /usr/share/locale
-       mv $(CURDIR)/debian/webcit/var/lib/citadel/www/locale \
-               $(CURDIR)/debian/citadel-webcit/usr/share/doc/citadel-webcit/examples/
-
-       cd $(CURDIR)/debian/citadel-webcit/usr/share/doc/citadel-webcit/examples/; \
-                               md5sum `find -type f |grep -v md5sums `>md5sums; 
-       mv $(CURDIR)/debian/webcit/var/lib/citadel/www/setup \
-               $(CURDIR)/debian/citadel-webcit/usr/lib/citadel-webcit/
-       mv $(CURDIR)/debian/webcit/var/lib/citadel/www/webserver \
-               $(CURDIR)/debian/citadel-webcit/usr/sbin/
+       export root=$(CURDIR)/debian/citadel-webcit; \
+               $(MAKE) install DESTDIR=$(CURDIR)/debian/citadel-webcit
+       mkdir -p $(CURDIR)/debian/citadel-webcit/usr/lib/citadel-webcit ;\
+       mv $(CURDIR)/debian/citadel-webcit/usr/sbin/setup \
+               $(CURDIR)/debian/citadel-webcit/usr/lib/citadel-webcit/; \
+       cd $(CURDIR)/debian/citadel-webcit/usr/share/doc/citadel-webcit/examples/ && \
+                               md5sum `find -type f |grep -v md5sums `>md5sums; \
 
 
 # Build architecture-independent files here.
@@ -99,23 +87,15 @@ binary-arch: build install
        dh_installdocs
        dh_installexamples
 #      dh_install
-#      dh_installmenu
        dh_installdebconf       
 #      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
 #      dh_installinit
 #      dh_installcron
-#      dh_installinfo
        dh_installman
        dh_link
        dh_strip
        dh_compress
        dh_fixperms
-#      dh_perl
-#      dh_python
-#      dh_makeshlibs
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol