]> code.citadel.org Git - citadel.git/blobdiff - webcit/debian/rules
* add the IO-Debug statement to the comment howto build .debs with devel support
[citadel.git] / webcit / debian / rules
index 0a62396a7ad18123328dc3c7ff7fa29a1a156ee6..31541862deaa15df9a15e910fc04d9b3313cea0d 100755 (executable)
@@ -17,14 +17,14 @@ DESTDIR=$(CURDIR)/debian/citadel-webcit
 
 EXTRA_ARGS=
 PROFILE_ARGS=
-#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling compression urldebug"
+#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling compression urldebug iodbg"
 
 ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
        PROFILE_ARGS= --with-gprof
        LDFLAGS += -pg 
 endif
 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0 -ggdb -rdynamic -MD -MP -D TECH_PREVIEW -pedantic
+       CFLAGS += -O0 -ggdb -rdynamic -MD -MP -D TECH_PREVIEW -pedantic -Wformat-nonliteral
        EXTRA_ARGS =  --with-backtrace
 else
        CFLAGS += -O2
@@ -33,6 +33,11 @@ ifneq (,$(findstring urldebug,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -D DEBUG_URLSTRINGS
 endif
 
+ifneq (,$(findstring iodbg,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -D SERV_TRACE
+endif
+
+
 configure: patch configure-stamp
 configure-stamp:
        dh_testdir
@@ -50,10 +55,8 @@ endif
                --with-localedir=/usr/share/ \
                --with-editordir=/usr/share/tinymce/www/ \
                --with-rundir=/var/run/citadel \
-               --with-ical --with-db --with-ldap \
                 --with-ssldir=/etc/ssl/webcit/ \
-               --with-ssl --with-libiconf \
-               --with-newt --with-included-gettext \
+               --with-ssl \
                --with-datadir=/var/run/citadel \
                --enable-debug $(EXTRA_ARGS) $(PROFILE_ARGS)