]> code.citadel.org Git - citadel.git/blobdiff - webcit/debian/rules
* add the IO-Debug statement to the comment howto build .debs with devel support
[citadel.git] / webcit / debian / rules
index d4109e17e9d39f50df0c5cca831a01d0e130cbf4..31541862deaa15df9a15e910fc04d9b3313cea0d 100755 (executable)
@@ -17,14 +17,14 @@ DESTDIR=$(CURDIR)/debian/citadel-webcit
 
 EXTRA_ARGS=
 PROFILE_ARGS=
-#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling compression urldebug"
+#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling compression urldebug iodbg"
 
 ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
        PROFILE_ARGS= --with-gprof
+       LDFLAGS += -pg 
 endif
 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0 -ggdb -rdynamic -MD -MP -D TECH_PREVIEW -pedantic
-       LDFLAGS += -pg 
+       CFLAGS += -O0 -ggdb -rdynamic -MD -MP -D TECH_PREVIEW -pedantic -Wformat-nonliteral
        EXTRA_ARGS =  --with-backtrace
 else
        CFLAGS += -O2
@@ -33,6 +33,11 @@ ifneq (,$(findstring urldebug,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -D DEBUG_URLSTRINGS
 endif
 
+ifneq (,$(findstring iodbg,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -D SERV_TRACE
+endif
+
+
 configure: patch configure-stamp
 configure-stamp:
        dh_testdir
@@ -48,12 +53,10 @@ endif
                --prefix=/usr/sbin/ \
                --with-wwwdir=/usr/share/citadel-webcit \
                --with-localedir=/usr/share/ \
-               --with-editordir=/usr/share/tinymce/www \
+               --with-editordir=/usr/share/tinymce/www/ \
                --with-rundir=/var/run/citadel \
-               --with-ical --with-db --with-ldap \
                 --with-ssldir=/etc/ssl/webcit/ \
-               --with-ssl --with-libiconf \
-               --with-newt --with-included-gettext \
+               --with-ssl \
                --with-datadir=/var/run/citadel \
                --enable-debug $(EXTRA_ARGS) $(PROFILE_ARGS)
 
@@ -62,7 +65,7 @@ endif
 
 build: build-stamp
 
-build-stamp: configure
+build-stamp: configure-stamp
        dh_testdir
 
 # Add here commands to compile the package.
@@ -70,7 +73,7 @@ build-stamp: configure
 
        touch build-stamp
 
-clean:
+clean: configure-stamp
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
@@ -87,6 +90,8 @@ install: build
        dh_clean -k 
        dh_installdirs
        $(MAKE) install-bin install-locale install-wwwdata DESTDIR=$(DESTDIR)
+       chmod a-x -R $(DESTDIR)/usr/share/citadel-webcit/static/*
+       find $(DESTDIR)/usr/share/locale/ -name webcit.mo -exec chmod a-x {} \;
        rm $(DESTDIR)/usr/share/citadel-webcit/static/prototype.js
 #      mkdir -p $(DESTDIR)/etc/citadel; cp webcit.conf $(DESTDIR)/etc/citadel/