]> code.citadel.org Git - citadel.git/blobdiff - webcit/debian/rules
* corrected use of our absolute directories
[citadel.git] / webcit / debian / rules
index 7fd18646e82464c573fdeefd6dd3c687f947a768..3181109629b2715e13cc9a430d498443d1aa0ec7 100755 (executable)
@@ -9,6 +9,7 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
+DESTDIR=$(CURDIR)/debian/citadel-webcit
 
 
 
@@ -23,17 +24,17 @@ endif
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       rm -rf $(CURDIR)/debian/webcit $(CURDIR)/debian/citadel-webcit $(CURDIR)/debian/citadel-webcit-apache
        CFLAGS="$(CFLAGS)" ./configure \
                --host=$(DEB_HOST_GNU_TYPE) \
                --build=$(DEB_BUILD_GNU_TYPE) \
-               --prefix=/usr \
-               --with-webcit-dir=/usr \
-               --with-sysconfdir=/etc/citadel \
-               --with-spooldir=/var/spool/citadel \
-               --with-staticdir=/usr/share/doc/citadel-webcit/examples \
+               --prefix=/usr/sbin/ \
+               --with-wwwdir=/usr/share/citadel-webcit \
+               --with-localedir=/usr/share/ \
+               --with-editordir=/usr/share/tinymce/www \
                --with-rundir=/var/run/citadel \
-               --with-ical --with-db --with-ldap --with-zlib --with-ssl --with-libiconf --with-newt --with-included-gettext
+               --with-ical --with-db --with-ldap \
+               --with-zlib --with-ssl --with-libiconf \
+               --with-newt --with-included-gettext
 
        touch configure-stamp
 
@@ -43,9 +44,9 @@ build: build-stamp
 build-stamp: configure-stamp 
        dh_testdir
 
-       # Add here commands to compile the package.
+# Add here commands to compile the package.
        $(MAKE)
-       #docbook-to-man debian/webcit.sgml > webcit.1
+#docbook-to-man debian/webcit.sgml > webcit.1
 
        touch build-stamp
 
@@ -54,7 +55,7 @@ clean:
        dh_testroot
        rm -f build-stamp configure-stamp
 
-       # Add here commands to clean up after the build process.
+# Add here commands to clean up after the build process.
        -$(MAKE) clean
 
        dh_clean 
@@ -64,16 +65,9 @@ install: build
        dh_testroot
        dh_clean -k 
        dh_installdirs
+       $(MAKE) install-bin install-locale install-wwwdata DESTDIR=$(DESTDIR)
+#      mkdir -p $(DESTDIR)/etc/citadel; cp webcit.conf $(DESTDIR)/etc/citadel/
 
-# Add here commands to install the package into debian/webcit.
-       root=$(CURDIR)/debian/webcit/
-       export root=$(CURDIR)/debian/citadel-webcit; \
-               $(MAKE) install DESTDIR=$(CURDIR)/debian/citadel-webcit
-       mkdir -p $(CURDIR)/debian/citadel-webcit/usr/lib/citadel-webcit ;\
-       mv $(CURDIR)/debian/citadel-webcit/usr/sbin/setup \
-               $(CURDIR)/debian/citadel-webcit/usr/lib/citadel-webcit/; \
-       cd $(CURDIR)/debian/citadel-webcit/usr/share/doc/citadel-webcit/examples/ && \
-                               md5sum `find -type f |grep -v md5sums `>md5sums; \
 
 
 # Build architecture-independent files here.
@@ -84,17 +78,17 @@ binary-indep: build install
 binary-arch: build install
        dh_testdir
        dh_testroot
-       dh_installchangelogs ChangeLog
+#      dh_installchangelogs ChangeLog
        dh_installdocs
        dh_installexamples
-#      dh_install
+       dh_install
 #      dh_installmenu
        dh_installdebconf       
 #      dh_installlogrotate
 #      dh_installemacsen
 #      dh_installpam
 #      dh_installmime
-#      dh_installinit
+       dh_installinit --name=webcit
 #      dh_installcron
 #      dh_installinfo
        dh_installman