]> code.citadel.org Git - citadel.git/blobdiff - webcit/debian/rules
* corrected use of our absolute directories
[citadel.git] / webcit / debian / rules
index d46918ae4169349a11fbacbe6a631708dde203f5..3181109629b2715e13cc9a430d498443d1aa0ec7 100755 (executable)
@@ -9,7 +9,7 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-DESTDIR=$(CURDIR)/debian/citadel-webcit/
+DESTDIR=$(CURDIR)/debian/citadel-webcit
 
 
 
@@ -27,11 +27,10 @@ configure-stamp:
        CFLAGS="$(CFLAGS)" ./configure \
                --host=$(DEB_HOST_GNU_TYPE) \
                --build=$(DEB_BUILD_GNU_TYPE) \
-               --prefix=/etc/citadel/www/ \
-               --with-localedir=/usr/share/locale \
-               --with-sysconfdir=/etc/citadel \
-               --with-spooldir=/var/spool/citadel \
-               --with-datadir=/etc/citadel \
+               --prefix=/usr/sbin/ \
+               --with-wwwdir=/usr/share/citadel-webcit \
+               --with-localedir=/usr/share/ \
+               --with-editordir=/usr/share/tinymce/www \
                --with-rundir=/var/run/citadel \
                --with-ical --with-db --with-ldap \
                --with-zlib --with-ssl --with-libiconf \
@@ -66,21 +65,9 @@ install: build
        dh_testroot
        dh_clean -k 
        dh_installdirs
+       $(MAKE) install-bin install-locale install-wwwdata DESTDIR=$(DESTDIR)
+#      mkdir -p $(DESTDIR)/etc/citadel; cp webcit.conf $(DESTDIR)/etc/citadel/
 
-# Add here commands to install the package into debian/webcit.
-       $(MAKE) -C . install DESTDIR=$(DESTDIR)
-# there are debian tinymce packages arround, so we don't ship it another time.
-       rm -rf $(DESTDIR)/etc/citadel/www/tiny_mce 
-# we don't use the setup anymore, omit it.
-       rm -f $(DESTDIR)/etc/citadel/www/setup
-# locale -> /usr/share/locale
-       mkdir -p $(DESTDIR)/usr/share/
-       mv $(DESTDIR)/etc/citadel/www/locale \
-               $(DESTDIR)/usr/share/locale
-
-       mkdir -p $(DESTDIR)/usr/sbin
-       mv $(DESTDIR)/etc/citadel/www/webserver \
-               $(DESTDIR)/usr/sbin/
 
 
 # Build architecture-independent files here.
@@ -94,7 +81,7 @@ binary-arch: build install
 #      dh_installchangelogs ChangeLog
        dh_installdocs
        dh_installexamples
-#      dh_install
+       dh_install
 #      dh_installmenu
        dh_installdebconf       
 #      dh_installlogrotate