]> code.citadel.org Git - citadel.git/blobdiff - webcit/debian/rules
* buildpackages can create deb source tarballs now.
[citadel.git] / webcit / debian / rules
index 9ce903b6caa2acf5a05299286c504f121cc731dc..61bb40a95ebba8a177c0cddc9548ea7b179ac340 100755 (executable)
@@ -31,7 +31,9 @@ configure-stamp:
                --with-spooldir=/var/spool/citadel \
                --with-datadir=/var/lib/citadel \
                --with-rundir=/var/run/citadel \
-               --with-ical --with-db --with-ldap --with-zlib --with-ssl --with-libiconf --with-newt --with-included-gettext
+               --with-ical --with-db --with-ldap \
+               --with-zlib --with-ssl --with-libiconf \
+               --with-newt --with-included-gettext
 
        touch configure-stamp
 
@@ -41,9 +43,9 @@ build: build-stamp
 build-stamp: configure-stamp 
        dh_testdir
 
-       # Add here commands to compile the package.
+# Add here commands to compile the package.
        $(MAKE)
-       #docbook-to-man debian/webcit.sgml > webcit.1
+#docbook-to-man debian/webcit.sgml > webcit.1
 
        touch build-stamp
 
@@ -52,7 +54,7 @@ clean:
        dh_testroot
        rm -f build-stamp configure-stamp
 
-       # Add here commands to clean up after the build process.
+# Add here commands to clean up after the build process.
        -$(MAKE) clean
 
        dh_clean 
@@ -63,26 +65,25 @@ install: build
        dh_clean -k 
        dh_installdirs
 
-       # Add here commands to install the package into debian/webcit.
+# Add here commands to install the package into debian/webcit.
        root=$(CURDIR)/debian/webcit/
        mkdir -p $(CURDIR)/debian/webcit/var/lib/citadel/www/
        export root=$(CURDIR)/debian/webcit; $(MAKE) install DESTDIR=$(CURDIR)/debian/webcit/
        mkdir -p $(CURDIR)/debian/citadel-webcit/usr/share/doc/citadel-webcit/examples
        mkdir -p $(CURDIR)/debian/citadel-webcit/usr/share/doc/citadel-webcit/contrib
        mkdir -p $(CURDIR)/debian/citadel-webcit/usr/sbin
-       mkdir -p $(CURDIR)/debian/citadel-webcit/usr/lib/citadel-webcit/
+       mkdir -p $(CURDIR)/debian/citadel-webcit/usr/lib/citadel-webcit/ 
        mv $(CURDIR)/debian/webcit/var/lib/citadel/www/static \
                $(CURDIR)/debian/citadel-webcit/usr/share/doc/citadel-webcit/examples/
        mv $(CURDIR)/debian/webcit/var/lib/citadel/www/tiny_mce \
                $(CURDIR)/debian/citadel-webcit/usr/share/doc/citadel-webcit/examples/
-# TODO: locale -> /usr/share/locale
+# locale -> /usr/share/locale
        mv $(CURDIR)/debian/webcit/var/lib/citadel/www/locale \
-               $(CURDIR)/debian/citadel-webcit/usr/share/doc/citadel-webcit/examples/
-
+               $(CURDIR)/debian/citadel-webcit/usr/share/locale
        cd $(CURDIR)/debian/citadel-webcit/usr/share/doc/citadel-webcit/examples/; \
                                md5sum `find -type f |grep -v md5sums `>md5sums; 
-       mv $(CURDIR)/debian/webcit/var/lib/citadel/www/setup \
-               $(CURDIR)/debian/citadel-webcit/usr/lib/citadel-webcit/
+# we don't use the setup anymore, omit it.
+       rm -f $(CURDIR)/debian/webcit/var/lib/citadel/www/setup
        mv $(CURDIR)/debian/webcit/var/lib/citadel/www/webserver \
                $(CURDIR)/debian/citadel-webcit/usr/sbin/
 
@@ -95,7 +96,7 @@ binary-indep: build install
 binary-arch: build install
        dh_testdir
        dh_testroot
-       dh_installchangelogs ChangeLog
+#      dh_installchangelogs ChangeLog
        dh_installdocs
        dh_installexamples
 #      dh_install
@@ -105,7 +106,7 @@ binary-arch: build install
 #      dh_installemacsen
 #      dh_installpam
 #      dh_installmime
-#      dh_installinit
+       dh_installinit --name=webcit
 #      dh_installcron
 #      dh_installinfo
        dh_installman