]> code.citadel.org Git - citadel.git/blobdiff - webcit/debian/rules
* add way to build the debs with url debugging
[citadel.git] / webcit / debian / rules
index 15846013d6c2529885dc65147d7c4ae4c70d29cb..649784d261320e15b82779fa46c1e791463e4ce6 100755 (executable)
@@ -13,17 +13,27 @@ DESTDIR=$(CURDIR)/debian/citadel-webcit
 
 EXTRA_ARGS=
 PROFILE_ARGS=
-#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling"
+#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling compression urldebug"
+
+
+ifneq (,$(findstring compression,$(DEB_BUILD_OPTIONS)))
+       ZLIB_ARGS=--without-zlib
+else
+       ZLIB_ARGS=--with-zlib
+endif
 ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
        PROFILE_ARGS= --with-gprof
 endif
 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0 -ggdb -rdynamic -MD -MP 
+       CFLAGS += -O0 -ggdb -rdynamic -MD -MP -D TECH_PREVIEW
        LDFLAGS += -pg 
        EXTRA_ARGS =  --with-backtrace
 else
        CFLAGS += -O2
 endif
+ifneq (,$(findstring urldebug,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -D DEBUG_URLSTRINGS
+endif
 
 configure: configure-stamp
 configure-stamp:
@@ -38,7 +48,7 @@ configure-stamp:
                --with-rundir=/var/run/citadel \
                --with-ical --with-db --with-ldap \
                 --with-ssldir=/etc/ssl/webcit/ \
-               --with-zlib --with-ssl --with-libiconf \
+               $(ZLIB_ARGS) --with-ssl --with-libiconf \
                --with-newt --with-included-gettext \
                --with-datadir=/var/run/citadel \
                --enable-debug $(EXTRA_ARGS) $(PROFILE_ARGS)
@@ -73,6 +83,7 @@ install: build
        dh_clean -k 
        dh_installdirs
        $(MAKE) install-bin install-locale install-wwwdata DESTDIR=$(DESTDIR)
+       rm $(DESTDIR)/usr/share/citadel-webcit/static/prototype.js
 #      mkdir -p $(DESTDIR)/etc/citadel; cp webcit.conf $(DESTDIR)/etc/citadel/