]> code.citadel.org Git - citadel.git/blobdiff - webcit/debian/rules
* add way to build the debs with url debugging
[citadel.git] / webcit / debian / rules
index bbdd4152d20f0641bc1e1b98335eb29197042046..649784d261320e15b82779fa46c1e791463e4ce6 100755 (executable)
@@ -13,17 +13,27 @@ DESTDIR=$(CURDIR)/debian/citadel-webcit
 
 EXTRA_ARGS=
 PROFILE_ARGS=
-#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling"
+#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling compression urldebug"
+
+
+ifneq (,$(findstring compression,$(DEB_BUILD_OPTIONS)))
+       ZLIB_ARGS=--without-zlib
+else
+       ZLIB_ARGS=--with-zlib
+endif
 ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
        PROFILE_ARGS= --with-gprof
 endif
 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0 -ggdb -rdynamic -D_GNU_SOURCE -MD -MP 
+       CFLAGS += -O0 -ggdb -rdynamic -MD -MP -D TECH_PREVIEW
        LDFLAGS += -pg 
        EXTRA_ARGS =  --with-backtrace
 else
        CFLAGS += -O2
 endif
+ifneq (,$(findstring urldebug,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -D DEBUG_URLSTRINGS
+endif
 
 configure: configure-stamp
 configure-stamp:
@@ -37,8 +47,10 @@ configure-stamp:
                --with-editordir=/usr/share/tinymce/www \
                --with-rundir=/var/run/citadel \
                --with-ical --with-db --with-ldap \
-               --with-zlib --with-ssl --with-libiconf \
+                --with-ssldir=/etc/ssl/webcit/ \
+               $(ZLIB_ARGS) --with-ssl --with-libiconf \
                --with-newt --with-included-gettext \
+               --with-datadir=/var/run/citadel \
                --enable-debug $(EXTRA_ARGS) $(PROFILE_ARGS)
 
        touch configure-stamp
@@ -71,6 +83,7 @@ install: build
        dh_clean -k 
        dh_installdirs
        $(MAKE) install-bin install-locale install-wwwdata DESTDIR=$(DESTDIR)
+       rm $(DESTDIR)/usr/share/citadel-webcit/static/prototype.js
 #      mkdir -p $(DESTDIR)/etc/citadel; cp webcit.conf $(DESTDIR)/etc/citadel/
 
 
@@ -83,7 +96,7 @@ binary-indep: build install
 binary-arch: build install
        dh_testdir
        dh_testroot
-#      dh_installchangelogs ChangeLog
+       dh_installchangelogs
        dh_installdocs
        dh_installexamples
        dh_install