]> code.citadel.org Git - citadel.git/blobdiff - webcit/debian/rules
* reorder zlib detection
[citadel.git] / webcit / debian / rules
index d3d67d683ce0bef48f8ff3c7ad5df7356f89787b..c837f23f917a0df3a7e1d5bd76b5a5d457316d5b 100755 (executable)
@@ -9,15 +9,24 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
+DESTDIR=$(CURDIR)/debian/citadel-webcit
 
+EXTRA_ARGS=
+PROFILE_ARGS=
+#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling compression urldebug"
 
-
-CFLAGS = -Wall -g -ggdb
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0
+ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
+       PROFILE_ARGS= --with-gprof
+endif
+ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -O0 -ggdb -rdynamic -MD -MP -D TECH_PREVIEW
+       LDFLAGS += -pg 
+       EXTRA_ARGS =  --with-backtrace
 else
-       CFLAGS += -O0 -ggdb
+       CFLAGS += -O2
+endif
+ifneq (,$(findstring urldebug,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -D DEBUG_URLSTRINGS
 endif
 
 configure: configure-stamp
@@ -26,12 +35,17 @@ configure-stamp:
        CFLAGS="$(CFLAGS)" ./configure \
                --host=$(DEB_HOST_GNU_TYPE) \
                --build=$(DEB_BUILD_GNU_TYPE) \
-               --prefix=/var/lib/citadel/www/ \
-               --with-sysconfdir=/etc/citadel \
-               --with-spooldir=/var/spool/citadel \
-               --with-datadir=/var/lib/citadel \
+               --prefix=/usr/sbin/ \
+               --with-wwwdir=/usr/share/citadel-webcit \
+               --with-localedir=/usr/share/ \
+               --with-editordir=/usr/share/tinymce/www \
                --with-rundir=/var/run/citadel \
-               --with-ical --with-db --with-ldap --with-zlib --with-ssl --with-libiconf --with-newt --with-included-gettext
+               --with-ical --with-db --with-ldap \
+                --with-ssldir=/etc/ssl/webcit/ \
+               --with-ssl --with-libiconf \
+               --with-newt --with-included-gettext \
+               --with-datadir=/var/run/citadel \
+               --enable-debug $(EXTRA_ARGS) $(PROFILE_ARGS)
 
        touch configure-stamp
 
@@ -41,9 +55,9 @@ build: build-stamp
 build-stamp: configure-stamp 
        dh_testdir
 
-       # Add here commands to compile the package.
+# Add here commands to compile the package.
        $(MAKE)
-       #docbook-to-man debian/webcit.sgml > webcit.1
+#docbook-to-man debian/webcit.sgml > webcit.1
 
        touch build-stamp
 
@@ -52,7 +66,7 @@ clean:
        dh_testroot
        rm -f build-stamp configure-stamp
 
-       # Add here commands to clean up after the build process.
+# Add here commands to clean up after the build process.
        -$(MAKE) clean
 
        dh_clean 
@@ -62,28 +76,10 @@ install: build
        dh_testroot
        dh_clean -k 
        dh_installdirs
+       $(MAKE) install-bin install-locale install-wwwdata DESTDIR=$(DESTDIR)
+       rm $(DESTDIR)/usr/share/citadel-webcit/static/prototype.js
+#      mkdir -p $(DESTDIR)/etc/citadel; cp webcit.conf $(DESTDIR)/etc/citadel/
 
-# Add here commands to install the package into debian/webcit.
-       root=$(CURDIR)/debian/webcit/
-       mkdir -p $(CURDIR)/debian/webcit/var/lib/citadel/www/
-       export root=$(CURDIR)/debian/webcit; $(MAKE) install DESTDIR=$(CURDIR)/debian/webcit/
-       mkdir -p $(CURDIR)/debian/citadel-webcit/usr/share/doc/citadel-webcit/examples
-       mkdir -p $(CURDIR)/debian/citadel-webcit/usr/share/doc/citadel-webcit/contrib
-       mkdir -p $(CURDIR)/debian/citadel-webcit/usr/sbin
-       mkdir -p $(CURDIR)/debian/citadel-webcit/usr/lib/citadel-webcit/ 
-       mv $(CURDIR)/debian/webcit/var/lib/citadel/www/static \
-               $(CURDIR)/debian/citadel-webcit/usr/share/doc/citadel-webcit/examples/
-       mv $(CURDIR)/debian/webcit/var/lib/citadel/www/tiny_mce \
-               $(CURDIR)/debian/citadel-webcit/usr/share/doc/citadel-webcit/examples/
-# locale -> /usr/share/locale
-       mv $(CURDIR)/debian/webcit/var/lib/citadel/www/locale \
-               $(CURDIR)/debian/citadel-webcit/usr/share/locale
-       cd $(CURDIR)/debian/citadel-webcit/usr/share/doc/citadel-webcit/examples/; \
-                               md5sum `find -type f |grep -v md5sums `>md5sums; 
-       mv $(CURDIR)/debian/webcit/var/lib/citadel/www/setup \
-               $(CURDIR)/debian/citadel-webcit/usr/lib/citadel-webcit/
-       mv $(CURDIR)/debian/webcit/var/lib/citadel/www/webserver \
-               $(CURDIR)/debian/citadel-webcit/usr/sbin/
 
 
 # Build architecture-independent files here.
@@ -94,17 +90,17 @@ binary-indep: build install
 binary-arch: build install
        dh_testdir
        dh_testroot
-       dh_installchangelogs ChangeLog
+       dh_installchangelogs
        dh_installdocs
        dh_installexamples
-#      dh_install
+       dh_install
 #      dh_installmenu
        dh_installdebconf       
 #      dh_installlogrotate
 #      dh_installemacsen
 #      dh_installpam
 #      dh_installmime
-#      dh_installinit
+       dh_installinit --name=webcit
 #      dh_installcron
 #      dh_installinfo
        dh_installman