]> code.citadel.org Git - citadel.git/blobdiff - webcit/debian/rules
* tiny 'file'-extract, now we can detect the type of an image. and set the mimetype...
[citadel.git] / webcit / debian / rules
index 1c5c346abf0e21970f96894d2f2d656f26ddb99e..ca73ada2140c5c4a066ef8fca739ddf51168bcdb 100755 (executable)
@@ -18,7 +18,7 @@ ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
        PROFILE_ARGS= --with-gprof
 endif
 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0 -ggdb -rdynamic -MD -MP 
+       CFLAGS += -O0 -ggdb -rdynamic -MD -MP -D TECH_PREVIEW
        LDFLAGS += -pg 
        EXTRA_ARGS =  --with-backtrace
 else
@@ -40,6 +40,7 @@ configure-stamp:
                 --with-ssldir=/etc/ssl/webcit/ \
                --with-zlib --with-ssl --with-libiconf \
                --with-newt --with-included-gettext \
+               --with-datadir=/var/run/citadel \
                --enable-debug $(EXTRA_ARGS) $(PROFILE_ARGS)
 
        touch configure-stamp
@@ -84,7 +85,7 @@ binary-indep: build install
 binary-arch: build install
        dh_testdir
        dh_testroot
-#      dh_installchangelogs ChangeLog
+       dh_installchangelogs
        dh_installdocs
        dh_installexamples
        dh_install