]> code.citadel.org Git - citadel.git/blobdiff - webcit/debian/rules
* fix dropdown
[citadel.git] / webcit / debian / rules
index 3181109629b2715e13cc9a430d498443d1aa0ec7..cea5888c32a41c50a65f3815cd872953296d44ba 100755 (executable)
 
 DESTDIR=$(CURDIR)/debian/citadel-webcit
 
+EXTRA_ARGS=
+PROFILE_ARGS=
+#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling compression urldebug"
 
-
-CFLAGS = -Wall -g -ggdb
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0
+ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
+       PROFILE_ARGS= --with-gprof
+endif
+ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -O0 -ggdb -rdynamic -MD -MP -D TECH_PREVIEW -pedantic
+       LDFLAGS += -pg 
+       EXTRA_ARGS =  --with-backtrace
 else
-       CFLAGS += -O0 -ggdb
+       CFLAGS += -O2
+endif
+ifneq (,$(findstring urldebug,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -D DEBUG_URLSTRINGS
 endif
 
 configure: configure-stamp
@@ -33,8 +41,11 @@ configure-stamp:
                --with-editordir=/usr/share/tinymce/www \
                --with-rundir=/var/run/citadel \
                --with-ical --with-db --with-ldap \
-               --with-zlib --with-ssl --with-libiconf \
-               --with-newt --with-included-gettext
+                --with-ssldir=/etc/ssl/webcit/ \
+               --with-ssl --with-libiconf \
+               --with-newt --with-included-gettext \
+               --with-datadir=/var/run/citadel \
+               --enable-debug $(EXTRA_ARGS) $(PROFILE_ARGS)
 
        touch configure-stamp
 
@@ -66,6 +77,7 @@ install: build
        dh_clean -k 
        dh_installdirs
        $(MAKE) install-bin install-locale install-wwwdata DESTDIR=$(DESTDIR)
+       rm $(DESTDIR)/usr/share/citadel-webcit/static/prototype.js
 #      mkdir -p $(DESTDIR)/etc/citadel; cp webcit.conf $(DESTDIR)/etc/citadel/
 
 
@@ -78,7 +90,7 @@ binary-indep: build install
 binary-arch: build install
        dh_testdir
        dh_testroot
-#      dh_installchangelogs ChangeLog
+       dh_installchangelogs
        dh_installdocs
        dh_installexamples
        dh_install