]> code.citadel.org Git - citadel.git/blobdiff - webcit/debian/rules
* fix dropdown
[citadel.git] / webcit / debian / rules
index 649784d261320e15b82779fa46c1e791463e4ce6..cea5888c32a41c50a65f3815cd872953296d44ba 100755 (executable)
@@ -15,17 +15,11 @@ EXTRA_ARGS=
 PROFILE_ARGS=
 #to enable debugging: export DEB_BUILD_OPTIONS="debug profiling compression urldebug"
 
-
-ifneq (,$(findstring compression,$(DEB_BUILD_OPTIONS)))
-       ZLIB_ARGS=--without-zlib
-else
-       ZLIB_ARGS=--with-zlib
-endif
 ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
        PROFILE_ARGS= --with-gprof
 endif
 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0 -ggdb -rdynamic -MD -MP -D TECH_PREVIEW
+       CFLAGS += -O0 -ggdb -rdynamic -MD -MP -D TECH_PREVIEW -pedantic
        LDFLAGS += -pg 
        EXTRA_ARGS =  --with-backtrace
 else
@@ -48,7 +42,7 @@ configure-stamp:
                --with-rundir=/var/run/citadel \
                --with-ical --with-db --with-ldap \
                 --with-ssldir=/etc/ssl/webcit/ \
-               $(ZLIB_ARGS) --with-ssl --with-libiconf \
+               --with-ssl --with-libiconf \
                --with-newt --with-included-gettext \
                --with-datadir=/var/run/citadel \
                --enable-debug $(EXTRA_ARGS) $(PROFILE_ARGS)