]> code.citadel.org Git - citadel.git/blobdiff - webcit/debian/rules
* fix dropdown
[citadel.git] / webcit / debian / rules
index 992fd5296718ed565c8c48dc4919fbaa3e248d6d..cea5888c32a41c50a65f3815cd872953296d44ba 100755 (executable)
@@ -13,24 +13,21 @@ DESTDIR=$(CURDIR)/debian/citadel-webcit
 
 EXTRA_ARGS=
 PROFILE_ARGS=
-#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling compression"
+#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling compression urldebug"
 
-
-ifneq (,$(findstring compression,$(DEB_BUILD_OPTIONS)))
-       ZLIB_ARGS=--without-zlib
-else
-       ZLIB_ARGS=--with-zlib
-endif
 ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
        PROFILE_ARGS= --with-gprof
 endif
 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0 -ggdb -rdynamic -MD -MP -D TECH_PREVIEW
+       CFLAGS += -O0 -ggdb -rdynamic -MD -MP -D TECH_PREVIEW -pedantic
        LDFLAGS += -pg 
        EXTRA_ARGS =  --with-backtrace
 else
        CFLAGS += -O2
 endif
+ifneq (,$(findstring urldebug,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -D DEBUG_URLSTRINGS
+endif
 
 configure: configure-stamp
 configure-stamp:
@@ -45,7 +42,7 @@ configure-stamp:
                --with-rundir=/var/run/citadel \
                --with-ical --with-db --with-ldap \
                 --with-ssldir=/etc/ssl/webcit/ \
-               $(ZLIB_ARGS) --with-ssl --with-libiconf \
+               --with-ssl --with-libiconf \
                --with-newt --with-included-gettext \
                --with-datadir=/var/run/citadel \
                --enable-debug $(EXTRA_ARGS) $(PROFILE_ARGS)