More places to remove the experimental #if
[citadel.git] / citadel / configure.ac
index 1beae85af54da258039533d19f789323e6ba2676..12d054fa28d053f58fac22932901b85d59744f4f 100644 (file)
@@ -367,7 +367,7 @@ if test "$GCC" = yes; then
                                CFLAGS="$CFLAGS -Wall -Wcast-qual -Wcast-align -Wno-char-subscripts $PTHREAD_DEFS"
                        ;;
                        *)
-                       CFLAGS="$CFLAGS -Wall -Wcast-qual -Wcast-align -Wstrict-prototypes $PTHREAD_DEFS"
+                       CFLAGS="$CFLAGS -Wall -Wcast-qual -Wcast-align -Wstrict-prototypes -Wno-strict-aliasing $PTHREAD_DEFS"
                        ;;
                esac
        fi
@@ -467,16 +467,6 @@ AC_ARG_WITH(gprof,
                        ]
 )
 
-dnl disable thread table reporting
-AC_ARG_WITH(threadlog,
-               [  --with-threadlog        enable logging of thread table],
-                       [ if test "x$withval" != "xno" ; then
-                               AC_DEFINE(WITH_THREADLOG, [], [Define if you want logging of the thread tables.])
-                         fi
-                       ]
-)
-
-
 if test "$ac_cv_func_gethostbyname" = no; then
        AC_CHECK_LIB(nsl, gethostbyname)
 fi
@@ -578,20 +568,13 @@ AC_CHECK_HEADER(libcitadel.h,
 CFLAGS="$saved_CFLAGS"
 
 
-dnl experimental libev smtp client remove this to...
-AC_DEFINE(EXPERIMENTAL_SMTP_EVENT_CLIENT, [], [should we use the experimental libevent smtp client?])
-dnl here...
-
-
-
-
-                AC_CHECK_LIB(cares, ares_init,
-                  [
+AC_CHECK_LIB(cares, ares_init,
+            [
                     C_ARES_LIBS=-lcares
-                AC_DEFINE(HAVE_C_ARES, 1, [Define to use c-ares library])
-                have_good_c_ares=yes
-                  ],, $SOCKET_LIBS $NSL_LIBS
-                )
+                   AC_DEFINE(HAVE_C_ARES, 1, [Define to use c-ares library])
+                    have_good_c_ares=yes
+            ],, $SOCKET_LIBS $NSL_LIBS
+)
 
 
 
@@ -788,22 +771,6 @@ fi
 
 
 
-dnl Checks for the Boehm-Demers-Weiser garbage collection library.
-if test "x$with_gc" != xno ; then
-       AC_CHECK_HEADERS(gc/gc_local_alloc.h,
-               [AC_CHECK_LIB(gc, GC_init,
-                       [ok_gc=yes],,
-       )])
-fi
-
-if test "x$ok_gc" = xyes ; then
-       SERVER_LIBS="-lgc $SERVER_LIBS"
-       AC_DEFINE(HAVE_GC, [], [define this if you have Boehm-Demers-Weiser available])
-fi
-
-
-
-
 
 dnl Checks for the libdspam mail spam scanning library.
 dnl if test "x$with_libdspam" != xno ; then
@@ -1071,7 +1038,6 @@ STRUCT_UCRED
 
 
 dnl Done! Now write the Makefile and sysdep.h
-AC_SUBST(AUTH)
 AC_SUBST(RESOLV)
 AC_SUBST(chkpwd_LIBS)
 AC_SUBST(TARGETS)