Version number set to 7.87, tagging for stable release
[citadel.git] / citadel / configure.ac
index 3803da167ee0cc7730c8337dde2bafb55cd42ce6..18fbf127bf0500ed2a17f074fba7ede6e03fe220 100644 (file)
@@ -1,7 +1,7 @@
 dnl Process this file with autoconf to produce a configure script.
 dnl $Id$
 AC_PREREQ(2.52)
-AC_INIT([Citadel], [7.80], [http://www.citadel.org/])
+AC_INIT([Citadel], [7.87], [http://www.citadel.org/])
 AC_REVISION([$Revision: 5108 $])
 AC_CONFIG_SRCDIR([citserver.c])
 AC_CONFIG_HEADER(sysdep.h)
@@ -710,7 +710,7 @@ fi
 
 dnl Checks for the Boehm-Demers-Weiser garbage collection library.
 if test "x$with_gc" != xno ; then
-       AC_CHECK_HEADERS(gc/gc.h,
+       AC_CHECK_HEADERS(gc/gc_local_alloc.h,
                [AC_CHECK_LIB(gc, GC_init,
                        [ok_gc=yes],,
        )])
@@ -796,7 +796,7 @@ dnl
 dnl TODO: for the DB header checks, we should check whether the headers
 dnl define db_env_create, somehow
 dnl
-AC_CHECK_HEADERS(curses.h dl.h fcntl.h limits.h malloc.h termios.h sys/ioctl.h sys/select.h sys/stat.h sys/time.h sys/prctl.h syslog.h unistd.h utmp.h utmpx.h paths.h db.h db4/db.h pthread.h netinet/in.h arpa/nameser.h arpa/nameser_compat.h)
+AC_CHECK_HEADERS(curses.h dl.h fcntl.h limits.h malloc.h termios.h sys/ioctl.h sys/select.h sys/stat.h sys/time.h sys/prctl.h syslog.h unistd.h utmp.h utmpx.h paths.h db.h db4/db.h pthread.h netinet/in.h arpa/nameser.h arpa/nameser_compat.h syscall.h sys/syscall.h)
 
 dnl
 dnl need to check if this is actually compilable, sometimes there are