Set all version numbers to 8.00 -- FEATURE FREEZE FOR 8.00
[citadel.git] / citadel / configure.ac
index 3e0a8cd35a8e882aeec13a30c28126cb88dd2570..1beae85af54da258039533d19f789323e6ba2676 100644 (file)
@@ -1,6 +1,6 @@
 dnl Process this file with autoconf to produce a configure script.
 AC_PREREQ(2.52)
-AC_INIT([Citadel], [7.83], [http://www.citadel.org/])
+AC_INIT([Citadel], [8.00], [http://www.citadel.org/])
 AC_REVISION([$Revision: 5108 $])
 AC_CONFIG_SRCDIR([citserver.c])
 AC_CONFIG_HEADER(sysdep.h)
@@ -9,9 +9,11 @@ AC_PREFIX_DEFAULT(/usr/local/citadel)
 if test "$prefix" = NONE; then
        AC_DEFINE_UNQUOTED(CTDLDIR, "$ac_default_prefix", [define this to the Citadel home directory])
        ssl_dir="$ac_default_prefix/keys"
+       localedir=$ac_default_prefix
 else
        AC_DEFINE_UNQUOTED(CTDLDIR, "$prefix", [define this to the Citadel home directory])
        ssl_dir="$prefix/keys"
+       localedir=$prefix
 fi
 
 dnl Make sure we see all GNU and Solaris extensions.
@@ -154,6 +156,19 @@ AC_ARG_WITH(docdir,
                        ]
 )
 
+dnl where to put the locale files
+AC_ARG_WITH(localedir, 
+                   [  --with-localedir          directory to put the locale files to],
+                       [ if test "x$withval" != "xno" ; then
+                           localedir=$withval
+                         fi
+                       ]
+)
+AC_DEFINE_UNQUOTED(LOCALEDIR, "$localedir",[where to find our pot files])
+LOCALEDIR=$localedir
+AC_SUBST(LOCALEDIR)
+
+
 
 dnl Checks for the zlib compression library.
 if test "x$with_zlib" != xno ; then
@@ -422,11 +437,11 @@ if test "$ok_nls" != "no"; then
 fi
 
 if test "$ok_nls" != "no"; then
-       AC_MSG_RESULT(WebCit will be built with national language support.)
+       AC_MSG_RESULT(citadel will be built with national language support.)
        AC_DEFINE(ENABLE_NLS, [], [whether we have NLS support])
-       PROG_SUBDIRS="$PROG_SUBDIRS po"
+       PROG_SUBDIRS="$PROG_SUBDIRS po/citadel-setup"
 else
-       AC_MSG_RESULT(WebCit will be built without national language support.)
+       AC_MSG_RESULT(citadel will be built without national language support.)
 fi
 
 dnl disable backtrace if we don't want it.
@@ -563,6 +578,59 @@ AC_CHECK_HEADER(libcitadel.h,
 CFLAGS="$saved_CFLAGS"
 
 
+dnl experimental libev smtp client remove this to...
+AC_DEFINE(EXPERIMENTAL_SMTP_EVENT_CLIENT, [], [should we use the experimental libevent smtp client?])
+dnl here...
+
+
+
+
+                AC_CHECK_LIB(cares, ares_init,
+                  [
+                    C_ARES_LIBS=-lcares
+                AC_DEFINE(HAVE_C_ARES, 1, [Define to use c-ares library])
+                have_good_c_ares=yes
+                  ],, $SOCKET_LIBS $NSL_LIBS
+                )
+
+
+
+saved_CFLAGS="$CFLAGS"
+CFLAGS="$CFLAGS $SERVER_LIBS"
+dnl Check for libevent
+AC_CHECK_HEADER(ares.h,
+       [AC_CHECK_LIB(cares, ares_init,
+               [
+                       LIBS="-lcares $LIBS $SERVER_LIBS"
+               ],
+               [
+                       AC_MSG_ERROR(libc-ares was not found or is not usable.  Please install libc-ares.)
+               ]
+       )],
+       [
+               AC_MSG_ERROR(ares.h was not found or is not usable.  Please install libc-ares.)
+       ]
+)
+CFLAGS="$saved_CFLAGS"
+
+saved_CFLAGS="$CFLAGS"
+CFLAGS="$CFLAGS $SERVER_LIBS"
+dnl Check for libevent
+AC_CHECK_HEADER(ev.h,
+       [AC_CHECK_LIB(ev, libcitadel_version_string,
+               [
+                       LIBS="-lev -lm $LIBS $SERVER_LIBS"
+               ],
+               [
+                       AC_MSG_ERROR(libev was not found or is not usable.  Please install libev.)
+               ]
+       ,
+       )],
+       [
+               AC_MSG_ERROR(ev.h was not found or is not usable.  Please install libev.)
+       ]
+)
+CFLAGS="$saved_CFLAGS"
 
 # The big search for OpenSSL
 if test "$with_ssl" != "no"; then
@@ -1012,7 +1080,7 @@ AC_SUBST(SERVER_LDFLAGS)
 AC_SUBST(SERVER_LIBS)
 AC_SUBST(SETUP_LIBS)
 AC_CONFIG_FILES([Makefile])
-AC_OUTPUT(database_cleanup.sh)
+AC_OUTPUT(database_cleanup.sh po/citadel-setup/Makefile)
 
 if test -z "$DATABASE"; then
        AC_MSG_WARN([No database driver was found. Please install Berkeley DB.])