Tag stable-78x for 7.86 release
[citadel.git] / citadel / configure.ac
index 11097275c4a9fb6ef103a62d0e7c73653ab92f86..52241a1d129f691a3054be346ef8c3e982214f3d 100644 (file)
@@ -1,7 +1,7 @@
 dnl Process this file with autoconf to produce a configure script.
 dnl $Id$
 AC_PREREQ(2.52)
-AC_INIT([Citadel], [7.66], [http://www.citadel.org/])
+AC_INIT([Citadel], [7.86], [http://www.citadel.org/])
 AC_REVISION([$Revision: 5108 $])
 AC_CONFIG_SRCDIR([citserver.c])
 AC_CONFIG_HEADER(sysdep.h)
@@ -165,7 +165,7 @@ if test "x$with_zlib" != xno ; then
 fi
 
 if test "x$ok_zlib" = xyes ; then
-dnl  libcitadel will bring libz, so we don't need it here.     LDFLAGS="-lz $LDFLAGS" 
+       LDFLAGS="-lz $LDFLAGS" 
        AC_DEFINE(HAVE_ZLIB, [], [define this if you have zlib compression available])
 fi
 
@@ -252,6 +252,7 @@ AC_ARG_WITH(ncurses, [  --without-ncurses       don't use ncurses])
 
 AC_ARG_WITH(with_ldap, [  --with-ldap             use OpenLDAP client library])
 dnl AC_ARG_WITH(with_libdspam, [  --with-libdspam         use libdspam mail spam scanning library])
+AC_ARG_WITH(with_gc, [  --with-gc             use the Boehm-Demers-Weiser garbage collection library])
 
 if test "x$with_db" != xno -a "x$with_db" != xyes -a "$with_db"; then
        db_dir="$with_db"
@@ -405,7 +406,7 @@ dnl Checks for libraries.
 dnl We want to test for the following in libc before checking for their
 dnl respective libraries, because some systems (like Irix) have both, and the
 dnl non-libc versions may be broken.
-AC_CHECK_FUNCS(crypt gethostbyname connect flock getpwnam_r getpwuid_r)
+AC_CHECK_FUNCS(crypt gethostbyname connect flock getpwnam_r getpwuid_r getloadavg)
 
 
 dnl disable backtrace if we don't want it.
@@ -707,6 +708,23 @@ fi
 
 
 
+dnl Checks for the Boehm-Demers-Weiser garbage collection library.
+if test "x$with_gc" != xno ; then
+       AC_CHECK_HEADERS(gc/gc_local_alloc.h,
+               [AC_CHECK_LIB(gc, GC_init,
+                       [ok_gc=yes],,
+       )])
+fi
+
+if test "x$ok_gc" = xyes ; then
+       SERVER_LIBS="-lgc $SERVER_LIBS"
+       AC_DEFINE(HAVE_GC, [], [define this if you have Boehm-Demers-Weiser available])
+fi
+
+
+
+
+
 dnl Checks for the libdspam mail spam scanning library.
 dnl if test "x$with_libdspam" != xno ; then
 dnl    AC_CHECK_HEADERS(dspam/libdspam.h,
@@ -778,7 +796,7 @@ dnl
 dnl TODO: for the DB header checks, we should check whether the headers
 dnl define db_env_create, somehow
 dnl
-AC_CHECK_HEADERS(curses.h dl.h fcntl.h limits.h malloc.h termios.h sys/ioctl.h sys/select.h sys/stat.h sys/time.h sys/prctl.h syslog.h unistd.h utmp.h utmpx.h paths.h db.h db4/db.h pthread.h netinet/in.h arpa/nameser.h arpa/nameser_compat.h)
+AC_CHECK_HEADERS(curses.h dl.h fcntl.h limits.h malloc.h termios.h sys/ioctl.h sys/select.h sys/stat.h sys/time.h sys/prctl.h syslog.h unistd.h utmp.h utmpx.h paths.h db.h db4/db.h pthread.h netinet/in.h arpa/nameser.h arpa/nameser_compat.h syscall.h sys/syscall.h)
 
 dnl
 dnl need to check if this is actually compilable, sometimes there are
@@ -999,10 +1017,14 @@ fi
 abs_srcdir="`cd $srcdir && pwd`"
 abs_builddir="`pwd`"
 if test "$abs_srcdir" != "$abs_builddir"; then
-   ln -s $abs_srcdir/include $abs_builddir
-   ln -s $abs_srcdir/Make_sources $abs_builddir
-   ln -s $abs_srcdir/Make_modules $abs_builddir
-   ln -s $abs_srcdir/*.h $abs_builddir
+   ln -sf $abs_srcdir/include $abs_builddir
+   ln -sf $abs_srcdir/Make_sources $abs_builddir
+   ln -sf $abs_srcdir/Make_modules $abs_builddir
+   for i in $abs_srcdir/*.h ; do
+      if test "$abs_srcdir/sysdep.h" != "$i"; then
+         ln -sf $i $abs_builddir
+      fi
+   done
    for d in `/bin/ls $abs_srcdir/modules/`; do 
        (mkdir -p $abs_builddir/modules/$d) 
    done
@@ -1024,6 +1046,7 @@ fi
 echo ------------------------------------------------------------------------
 echo 'LDAP support:                    ' $ok_ldap
 echo 'Character set conversion support:' $ok_iconv
+echo 'Boehm-Demers-Weiser support:     ' $ok_gc
 dnl echo 'DSpam Scanning support:          ' $ok_libdspam
 echo 
 echo 'Note: if you are not using Linux, make sure you are using GNU make'