Tag stable-78x for 7.86 release
[citadel.git] / citadel / configure.ac
index ccd615106d0f8f55d96847a6f9390be72f244c06..52241a1d129f691a3054be346ef8c3e982214f3d 100644 (file)
@@ -1,7 +1,7 @@
 dnl Process this file with autoconf to produce a configure script.
 dnl $Id$
 AC_PREREQ(2.52)
-AC_INIT([Citadel], [7.70], [http://www.citadel.org/])
+AC_INIT([Citadel], [7.86], [http://www.citadel.org/])
 AC_REVISION([$Revision: 5108 $])
 AC_CONFIG_SRCDIR([citserver.c])
 AC_CONFIG_HEADER(sysdep.h)
@@ -710,7 +710,7 @@ fi
 
 dnl Checks for the Boehm-Demers-Weiser garbage collection library.
 if test "x$with_gc" != xno ; then
-       AC_CHECK_HEADERS(gc/gc.h,
+       AC_CHECK_HEADERS(gc/gc_local_alloc.h,
                [AC_CHECK_LIB(gc, GC_init,
                        [ok_gc=yes],,
        )])
@@ -796,7 +796,7 @@ dnl
 dnl TODO: for the DB header checks, we should check whether the headers
 dnl define db_env_create, somehow
 dnl
-AC_CHECK_HEADERS(curses.h dl.h fcntl.h limits.h malloc.h termios.h sys/ioctl.h sys/select.h sys/stat.h sys/time.h sys/prctl.h syslog.h unistd.h utmp.h utmpx.h paths.h db.h db4/db.h pthread.h netinet/in.h arpa/nameser.h arpa/nameser_compat.h)
+AC_CHECK_HEADERS(curses.h dl.h fcntl.h limits.h malloc.h termios.h sys/ioctl.h sys/select.h sys/stat.h sys/time.h sys/prctl.h syslog.h unistd.h utmp.h utmpx.h paths.h db.h db4/db.h pthread.h netinet/in.h arpa/nameser.h arpa/nameser_compat.h syscall.h sys/syscall.h)
 
 dnl
 dnl need to check if this is actually compilable, sometimes there are