Added --with-threadlog. Use this if you want the thread table written to
[citadel.git] / citadel / configure.ac
index 74e707208efad53ded8cc3b96064d192e6dcd1de..566eb7df4d706e82f1903c411646815612b46361 100644 (file)
@@ -333,6 +333,15 @@ AC_ARG_WITH(gprof,
                        ]
 )
 
+dnl disable thread table reporting
+AC_ARG_WITH(threadlog,
+               [ --with-threadlog      enable logging of thread table],
+                       [ if test "x$withval" != "xno" ; then
+                               AC_DEFINE(WITH_THREADLOG, [], [Define if you want logging of the thread tables.])
+                         fi
+                       ]
+)
+
 
 if test "$ac_cv_func_gethostbyname" = no; then
        AC_CHECK_LIB(nsl, gethostbyname)