changing internal version number to 8.12
[citadel.git] / citadel / configure.ac
index 6e8894d5bc49cf8c6addd90e013947ffae3fa7a7..7682cbb4024fb5665df49cf770dc06c25088640f 100644 (file)
@@ -1,6 +1,6 @@
 dnl Process this file with autoconf to produce a configure script.
 AC_PREREQ(2.52)
-AC_INIT([Citadel], [8.03], [http://www.citadel.org/])
+AC_INIT([Citadel], [8.12], [http://www.citadel.org/])
 AC_REVISION([$Revision: 5108 $])
 AC_CONFIG_SRCDIR([citserver.c])
 AC_CONFIG_HEADER(sysdep.h)
@@ -171,20 +171,23 @@ AC_SUBST(LOCALEDIR)
 
 
 dnl Checks for the zlib compression library.
-if test "x$with_zlib" != xno ; then
-       AC_CHECK_HEADERS(zlib.h,
-               [AC_CHECK_LIB(z, zlibVersion,
-                       [ok_zlib=yes],,
-       )])
-fi
-
-if test "x$ok_zlib" = xyes ; then
-       LDFLAGS="-lz $LDFLAGS" 
-       AC_DEFINE(HAVE_ZLIB, [], [define this if you have zlib compression available])
-fi
-
-
-
+saved_CFLAGS="$CFLAGS"
+CFLAGS="$CFLAGS $SERVER_LIBS"
+AC_CHECK_HEADER(zlib.h,
+       [AC_CHECK_LIB(z, zlibVersion,
+               [
+                       LIBS="-lz $LIBS $SERVER_LIBS"
+               ],
+               [
+                       AC_MSG_ERROR(zlib was not found or is not usable.  Please install zlib.)
+               ]
+       ,
+       )],
+       [
+               AC_MSG_ERROR(zlib.h was not found or is not usable.  Please install zlib.)
+       ]
+)
+CFLAGS="$saved_CFLAGS"
 
 dnl Here is the check for a libc integrated iconv
 AC_ARG_ENABLE(iconv,
@@ -602,40 +605,26 @@ saved_CFLAGS="$CFLAGS"
 CFLAGS="$CFLAGS $SERVER_LIBS"
 dnl Check for libev
 AC_CHECK_HEADER(ev.h,
-       [AC_CHECK_LIB(ev, libcitadel_version_string,
-               [
+       [AC_TRY_COMPILE([#include <math.h>
+#include <ev.h>], 
+                         [
+                        ev_cleanup abort_by_shutdown;
+                        struct ev_loop *event_base;
+                        ev_cleanup_start(event_base, &abort_by_shutdown);
+                       ],
+                       [
                        LIBS="-lev -lm $LIBS $SERVER_LIBS"
-               ],
+                       ],
                [
                        AC_MSG_ERROR(libev was not found or is not usable.  Please install libev.)
-               ]
-       ,
-       )],
+               ])
+       ],
        [
                AC_MSG_ERROR(ev.h was not found or is not usable.  Please install libev.)
        ]
 )
 CFLAGS="$saved_CFLAGS"
 
-AC_MSG_CHECKING(Checking version of libev)
-AC_TRY_RUN([
-       #include <ev.h>
-       main() {
-               printf("libev is version %d.%d\n", ev_version_major(), ev_version_minor());
-               if (ev_version_major() >= 4) {
-                       exit(0);
-               }
-               exit(1);
-       }
- ],
-               [
-                       AC_MSG_RESULT(This will do just fine, thank you)
-               ],
-               [ 
-                       AC_MSG_ERROR(Citadel requires a newer version of libev.  More info: http://www.citadel.org/doku.php/installation:start)
-               ]
-)
-
 
 # The big search for OpenSSL
 if test "$with_ssl" != "no"; then