changing internal version number to 8.12
[citadel.git] / citadel / configure.ac
index 8401e58b0e8013a162da797390595433b7fd3413..7682cbb4024fb5665df49cf770dc06c25088640f 100644 (file)
@@ -1,6 +1,6 @@
 dnl Process this file with autoconf to produce a configure script.
 AC_PREREQ(2.52)
-AC_INIT([Citadel], [8.03], [http://www.citadel.org/])
+AC_INIT([Citadel], [8.12], [http://www.citadel.org/])
 AC_REVISION([$Revision: 5108 $])
 AC_CONFIG_SRCDIR([citserver.c])
 AC_CONFIG_HEADER(sysdep.h)
@@ -605,15 +605,20 @@ saved_CFLAGS="$CFLAGS"
 CFLAGS="$CFLAGS $SERVER_LIBS"
 dnl Check for libev
 AC_CHECK_HEADER(ev.h,
-       [AC_CHECK_LIB(ev, ev_cleanup_start,
-               [
+       [AC_TRY_COMPILE([#include <math.h>
+#include <ev.h>], 
+                         [
+                        ev_cleanup abort_by_shutdown;
+                        struct ev_loop *event_base;
+                        ev_cleanup_start(event_base, &abort_by_shutdown);
+                       ],
+                       [
                        LIBS="-lev -lm $LIBS $SERVER_LIBS"
-               ],
+                       ],
                [
                        AC_MSG_ERROR(libev was not found or is not usable.  Please install libev.)
-               ]
-       ,
-       )],
+               ])
+       ],
        [
                AC_MSG_ERROR(ev.h was not found or is not usable.  Please install libev.)
        ]