disable warnings about strict aliasing; gcc does broken warnings here in conjunction...
[citadel.git] / citadel / configure.ac
index db8b1b6a947ebbca38acb34884c3ea2cd72897f0..7943c3bf9ce08072c2839c6e2dda12725cdd4c8b 100644 (file)
@@ -1,6 +1,6 @@
 dnl Process this file with autoconf to produce a configure script.
 AC_PREREQ(2.52)
-AC_INIT([Citadel], [7.89], [http://www.citadel.org/])
+AC_INIT([Citadel], [8.00], [http://www.citadel.org/])
 AC_REVISION([$Revision: 5108 $])
 AC_CONFIG_SRCDIR([citserver.c])
 AC_CONFIG_HEADER(sysdep.h)
@@ -9,9 +9,11 @@ AC_PREFIX_DEFAULT(/usr/local/citadel)
 if test "$prefix" = NONE; then
        AC_DEFINE_UNQUOTED(CTDLDIR, "$ac_default_prefix", [define this to the Citadel home directory])
        ssl_dir="$ac_default_prefix/keys"
+       localedir=$ac_default_prefix
 else
        AC_DEFINE_UNQUOTED(CTDLDIR, "$prefix", [define this to the Citadel home directory])
        ssl_dir="$prefix/keys"
+       localedir=$prefix
 fi
 
 dnl Make sure we see all GNU and Solaris extensions.
@@ -154,6 +156,19 @@ AC_ARG_WITH(docdir,
                        ]
 )
 
+dnl where to put the locale files
+AC_ARG_WITH(localedir, 
+                   [  --with-localedir          directory to put the locale files to],
+                       [ if test "x$withval" != "xno" ; then
+                           localedir=$withval
+                         fi
+                       ]
+)
+AC_DEFINE_UNQUOTED(LOCALEDIR, "$localedir",[where to find our pot files])
+LOCALEDIR=$localedir
+AC_SUBST(LOCALEDIR)
+
+
 
 dnl Checks for the zlib compression library.
 if test "x$with_zlib" != xno ; then
@@ -352,7 +367,7 @@ if test "$GCC" = yes; then
                                CFLAGS="$CFLAGS -Wall -Wcast-qual -Wcast-align -Wno-char-subscripts $PTHREAD_DEFS"
                        ;;
                        *)
-                       CFLAGS="$CFLAGS -Wall -Wcast-qual -Wcast-align -Wstrict-prototypes $PTHREAD_DEFS"
+                       CFLAGS="$CFLAGS -Wall -Wcast-qual -Wcast-align -Wstrict-prototypes -Wno-strict-aliasing $PTHREAD_DEFS"
                        ;;
                esac
        fi
@@ -422,11 +437,11 @@ if test "$ok_nls" != "no"; then
 fi
 
 if test "$ok_nls" != "no"; then
-       AC_MSG_RESULT(WebCit will be built with national language support.)
+       AC_MSG_RESULT(citadel will be built with national language support.)
        AC_DEFINE(ENABLE_NLS, [], [whether we have NLS support])
-       PROG_SUBDIRS="$PROG_SUBDIRS po"
+       PROG_SUBDIRS="$PROG_SUBDIRS po/citadel-setup"
 else
-       AC_MSG_RESULT(WebCit will be built without national language support.)
+       AC_MSG_RESULT(citadel will be built without national language support.)
 fi
 
 dnl disable backtrace if we don't want it.
@@ -452,16 +467,6 @@ AC_ARG_WITH(gprof,
                        ]
 )
 
-dnl disable thread table reporting
-AC_ARG_WITH(threadlog,
-               [  --with-threadlog        enable logging of thread table],
-                       [ if test "x$withval" != "xno" ; then
-                               AC_DEFINE(WITH_THREADLOG, [], [Define if you want logging of the thread tables.])
-                         fi
-                       ]
-)
-
-
 if test "$ac_cv_func_gethostbyname" = no; then
        AC_CHECK_LIB(nsl, gethostbyname)
 fi
@@ -563,6 +568,59 @@ AC_CHECK_HEADER(libcitadel.h,
 CFLAGS="$saved_CFLAGS"
 
 
+dnl experimental libev smtp client remove this to...
+AC_DEFINE(EXPERIMENTAL_SMTP_EVENT_CLIENT, [], [should we use the experimental libevent smtp client?])
+dnl here...
+
+
+
+
+                AC_CHECK_LIB(cares, ares_init,
+                  [
+                    C_ARES_LIBS=-lcares
+                AC_DEFINE(HAVE_C_ARES, 1, [Define to use c-ares library])
+                have_good_c_ares=yes
+                  ],, $SOCKET_LIBS $NSL_LIBS
+                )
+
+
+
+saved_CFLAGS="$CFLAGS"
+CFLAGS="$CFLAGS $SERVER_LIBS"
+dnl Check for libevent
+AC_CHECK_HEADER(ares.h,
+       [AC_CHECK_LIB(cares, ares_init,
+               [
+                       LIBS="-lcares $LIBS $SERVER_LIBS"
+               ],
+               [
+                       AC_MSG_ERROR(libc-ares was not found or is not usable.  Please install libc-ares.)
+               ]
+       )],
+       [
+               AC_MSG_ERROR(ares.h was not found or is not usable.  Please install libc-ares.)
+       ]
+)
+CFLAGS="$saved_CFLAGS"
+
+saved_CFLAGS="$CFLAGS"
+CFLAGS="$CFLAGS $SERVER_LIBS"
+dnl Check for libevent
+AC_CHECK_HEADER(ev.h,
+       [AC_CHECK_LIB(ev, libcitadel_version_string,
+               [
+                       LIBS="-lev -lm $LIBS $SERVER_LIBS"
+               ],
+               [
+                       AC_MSG_ERROR(libev was not found or is not usable.  Please install libev.)
+               ]
+       ,
+       )],
+       [
+               AC_MSG_ERROR(ev.h was not found or is not usable.  Please install libev.)
+       ]
+)
+CFLAGS="$saved_CFLAGS"
 
 # The big search for OpenSSL
 if test "$with_ssl" != "no"; then
@@ -720,22 +778,6 @@ fi
 
 
 
-dnl Checks for the Boehm-Demers-Weiser garbage collection library.
-if test "x$with_gc" != xno ; then
-       AC_CHECK_HEADERS(gc/gc_local_alloc.h,
-               [AC_CHECK_LIB(gc, GC_init,
-                       [ok_gc=yes],,
-       )])
-fi
-
-if test "x$ok_gc" = xyes ; then
-       SERVER_LIBS="-lgc $SERVER_LIBS"
-       AC_DEFINE(HAVE_GC, [], [define this if you have Boehm-Demers-Weiser available])
-fi
-
-
-
-
 
 dnl Checks for the libdspam mail spam scanning library.
 dnl if test "x$with_libdspam" != xno ; then
@@ -1012,7 +1054,7 @@ AC_SUBST(SERVER_LDFLAGS)
 AC_SUBST(SERVER_LIBS)
 AC_SUBST(SETUP_LIBS)
 AC_CONFIG_FILES([Makefile])
-AC_OUTPUT(database_cleanup.sh)
+AC_OUTPUT(database_cleanup.sh po/citadel-setup/Makefile)
 
 if test -z "$DATABASE"; then
        AC_MSG_WARN([No database driver was found. Please install Berkeley DB.])