* make backtrace optional.
[citadel.git] / citadel / configure.ac
index af09ef2d94cf0fece82f2cbee3541ea0b39abfad..79ce0e2dd30a4c35daa7f0ac0785a5691a03009c 100644 (file)
@@ -294,7 +294,18 @@ dnl Checks for libraries.
 dnl We want to test for the following in libc before checking for their
 dnl respective libraries, because some systems (like Irix) have both, and the
 dnl non-libc versions may be broken.
-AC_CHECK_FUNCS(crypt gethostbyname connect backtrace)
+AC_CHECK_FUNCS(crypt gethostbyname connect )
+
+
+dnl disable backtrace if we don't want it.
+AC_ARG_WITH(backtrace, 
+                   [  --with-backtrace          Disable backtrace dumps in the syslog],
+                       [ if test "x$withval" != "xno" ; then
+                             AC_CHECK_FUNCS(backtrace)
+                         fi
+                       ]
+)
+
 
 if test "$ac_cv_func_gethostbyname" = no; then
        AC_CHECK_LIB(nsl, gethostbyname)