Removed remnants of dspam module config
[citadel.git] / citadel / configure.ac
index eb09f1aa9bc89d460c87d20cb18abfc0aec8d911..94ba60de5ae4ea528232e6edcd66ea9ccc1cc770 100644 (file)
@@ -1,6 +1,6 @@
 dnl Process this file with autoconf to produce a configure script.
 AC_PREREQ(2.52)
-AC_INIT([Citadel], [8.10], [http://www.citadel.org/])
+AC_INIT([Citadel], [912], [http://www.citadel.org/])
 AC_REVISION([$Revision: 5108 $])
 AC_CONFIG_SRCDIR([citserver.c])
 AC_CONFIG_HEADER(sysdep.h)
@@ -247,11 +247,6 @@ fi
 
 AC_CHECK_LIB(intl, libintl_bindtextdomain, [LDFLAGS="$LDFLAGS -lintl"])
 
-
-
-AC_ARG_ENABLE(threaded-client, [  --disable-threaded-client
-                         disable multithreaded client])
-
 AC_ARG_ENABLE(pie, [  --enable-pie            build position-independent executables])
 
 AC_ARG_WITH(pam, [  --with-pam              use PAM if present (see PAM.txt before you try this)])
@@ -266,7 +261,6 @@ AC_ARG_WITH(ssl,
        ]
 )
 AC_ARG_WITH(with_ldap, [  --with-ldap             use OpenLDAP client library])
-dnl AC_ARG_WITH(with_libdspam, [  --with-libdspam         use libdspam mail spam scanning library])
 AC_ARG_WITH(with_gc, [  --with-gc             use the Boehm-Demers-Weiser garbage collection library])
 
 if test "x$with_db" != xno -a "x$with_db" != xyes -a "$with_db"; then
@@ -284,10 +278,6 @@ else
        test -d /usr/local/BerkeleyDB.4.5 && db_dir=/usr/local/BerkeleyDB.4.5
 fi
 
-dnl By default, we only build the client (citadel and whobbs) unless we can
-dnl figure out how to build with POSIX threads.
-TARGETS=client
-
 AC_CANONICAL_HOST
 PTHREAD_DEFS=-D_REENTRANT
 AC_MSG_CHECKING([how to compile with POSIX threads])
@@ -415,6 +405,7 @@ AC_CHECK_SIZEOF(short, 0)
 AC_CHECK_SIZEOF(int, 0)
 AC_CHECK_SIZEOF(long, 0)
 AC_CHECK_SIZEOF(size_t, 0)
+AC_CHECK_SIZEOF(loff_t, 0)
 dnl AC_CHECK_SIZEOF(long long, 0)
 
 dnl Checks for libraries.
@@ -422,7 +413,7 @@ dnl Checks for libraries.
 dnl We want to test for the following in libc before checking for their
 dnl respective libraries, because some systems (like Irix) have both, and the
 dnl non-libc versions may be broken.
-AC_CHECK_FUNCS(crypt gethostbyname connect flock getpwnam_r getpwuid_r getloadavg)
+AC_CHECK_FUNCS(crypt gethostbyname connect getpwnam_r getpwuid_r getloadavg)
 
 AC_CHECK_FUNCS(strftime_l uselocale gettext)
 
@@ -573,59 +564,6 @@ AC_CHECK_HEADER(libcitadel.h,
 CFLAGS="$saved_CFLAGS"
 
 
-AC_CHECK_LIB(cares, ares_parse_mx_reply,
-            [
-                    C_ARES_LIBS=-lcares
-                   AC_DEFINE(HAVE_C_ARES, 1, [Define to use c-ares library])
-                    have_good_c_ares=yes
-            ],, $SOCKET_LIBS $NSL_LIBS
-)
-
-
-
-saved_CFLAGS="$CFLAGS"
-CFLAGS="$CFLAGS $SERVER_LIBS"
-dnl Check for c-ares
-AC_CHECK_HEADER(ares.h,
-       [AC_CHECK_LIB(cares, ares_parse_mx_reply,
-               [
-                       LIBS="-lcares $LIBS $SERVER_LIBS"
-               ],
-               [
-                       AC_MSG_ERROR(libc-ares was not found or is not usable.  Please install libc-ares.)
-               ]
-       )],
-       [
-               AC_MSG_ERROR(ares.h was not found or is not usable.  Please install libc-ares.)
-       ]
-)
-CFLAGS="$saved_CFLAGS"
-
-saved_CFLAGS="$CFLAGS"
-CFLAGS="$CFLAGS $SERVER_LIBS"
-dnl Check for libev
-AC_CHECK_HEADER(ev.h,
-       [AC_TRY_COMPILE([#include <math.h>
-#include <ev.h>], 
-                         [
-                        ev_cleanup abort_by_shutdown;
-                        struct ev_loop *event_base;
-                        ev_cleanup_start(event_base, &abort_by_shutdown);
-                       ],
-                       [
-                       LIBS="-lev -lm $LIBS $SERVER_LIBS"
-                       ],
-               [
-                       AC_MSG_ERROR(libev was not found or is not usable.  Please install libev.)
-               ])
-       ],
-       [
-               AC_MSG_ERROR(ev.h was not found or is not usable.  Please install libev.)
-       ]
-)
-CFLAGS="$saved_CFLAGS"
-
-
 # The big search for OpenSSL
 if test "$with_ssl" != "no"; then
        saved_LIBS="$LIBS"
@@ -768,7 +706,7 @@ fi
 dnl Checks for the OpenLDAP client library.
 if test "x$with_ldap" != xno ; then
        AC_CHECK_HEADERS(ldap.h,
-               [AC_CHECK_LIB(ldap, ldap_init,
+               [AC_CHECK_LIB(ldap, ldap_initialize,
                        [ok_ldap=yes],,
        )])
 fi
@@ -783,21 +721,6 @@ fi
 
 
 
-dnl Checks for the libdspam mail spam scanning library.
-dnl if test "x$with_libdspam" != xno ; then
-dnl    AC_CHECK_HEADERS(dspam/libdspam.h,
-dnl            [AC_CHECK_LIB(dspam, dspam_init,
-dnl                    [ok_libdspam=yes],,
-dnl    )])
-dnl fi
-dnl 
-dnl if test "x$ok_libdspam" = xyes ; then
-dnl    SERVER_LIBS="-ldspam $SERVER_LIBS"
-dnl    AC_DEFINE(HAVE_LIBDSPAM, [], [(unfinished) define this if you have the libdspam mail spam scanning library available])
-dnl fi
-
-
-
 dnl Checks for the Expat XML parser.
 AC_CHECK_HEADER(expat.h,
        [AC_CHECK_LIB(expat, XML_ParserCreateNS,
@@ -996,14 +919,9 @@ AC_CACHE_CHECK([for pthread_create], ac_cv_func_pthread_create,
 #endif],
 ac_cv_func_pthread_create=yes, ac_cv_func_pthread_create=no)])
 if test "$ac_cv_func_pthread_create" = yes; then
-       test "$DATABASE" && TARGETS="client server utils"
-       if test "x$enable_threaded_client" != xno; then
-               AC_DEFINE(THREADED_CLIENT, [], [define this if you want to enable the multithreaded client])
-       fi
+       test "$DATABASE" && TARGETS="server utils"
 fi
 
-AC_REPLACE_FUNCS(snprintf getutline)
-
 AC_CACHE_CHECK([the weather], ac_cv_weather, [
        sleep 1
        echo $ECHO_N "opening your window... $ECHO_C" >&6
@@ -1084,7 +1002,6 @@ if test "$abs_srcdir" != "$abs_builddir"; then
    fi
    mkdir -p $abs_builddir/utils
    mkdir -p $abs_builddir/utillib
-   mkdir -p $abs_builddir/textclient
 fi
 
 if test -n "$srcdir"; then 
@@ -1096,7 +1013,6 @@ echo ------------------------------------------------------------------------
 echo 'LDAP support:                    ' $ok_ldap
 echo 'Character set conversion support:' $ok_iconv
 echo 'Boehm-Demers-Weiser support:     ' $ok_gc
-dnl echo 'DSpam Scanning support:          ' $ok_libdspam
 echo 
 echo 'Note: if you are not using Linux, make sure you are using GNU make'
 echo '(gmake) to compile Citadel.'