]> code.citadel.org Git - citadel.git/blobdiff - citadel/configure.ac
* move arround some files in the configured build according to the suggestions of...
[citadel.git] / citadel / configure.ac
index 7e05d5079ee8555b37e22ec5e213bc83ed54fe6d..9fbfe80aa9cc6fa55915aaceb83839c157ec622d 100644 (file)
@@ -30,6 +30,18 @@ AC_ARG_WITH(datadir,
                        ]
 )
 
+dnl Checks for the Datadir
+AC_ARG_WITH(staticdatadir, 
+                   [  --with-staticdatadir    directory to store citadels system messages under],
+                       [ if test "x$withval" != "xno" ; then
+                                                 AC_DEFINE(HAVE_STATICDATA_DIR)
+                                                 AC_DEFINE_UNQUOTED(STATICDATA_DIR, "$withval")
+                                                 MAKE_STATICDATA_DIR=$withval
+                                                 AC_SUBST(MAKE_STATICDATA_DIR)
+                         fi
+                       ]
+)
+
 
 dnl Checks for the SSLdir
 dnl this is a bit different than the rest, 
@@ -71,6 +83,18 @@ AC_ARG_WITH(sysconfdir,
                        ]
 )
 
+dnl Checks for where to put our utilities
+AC_ARG_WITH(utility-bindir, 
+                       [  --with-utility-bindir       directory where to find helper binaries],
+                       [ if test "x$withval" != "xno" ; then
+                                           AC_DEFINE(HAVE_UTILBIN_DIR)
+                                               AC_DEFINE_UNQUOTED(UTILBIN_DIR, "$withval")
+                                               MAKE_UTILBIN_DIR=$withval
+                                               AC_SUBST(MAKE_UTILBIN_DIR)
+                         fi
+                       ]
+)
+
 
 dnl Checks for the run-dir for the sockets
 AC_ARG_WITH(rundir, 
@@ -609,17 +633,22 @@ if test $ac_cv_struct_ut_type = yes; then
        AC_DEFINE(HAVE_UT_TYPE)
 fi
 
-AC_CACHE_CHECK([for call semantics from getpwuid_r], ac_cv_call_getpwuid_r,
-[AC_TRY_COMPILE([#include <sys/types.h>
-#include <pwd.h>], [
-  struct passwd pw, *pwp;
-  char pwbuf[64];
-  uid_t uid;
-
-  getpwuid_r(uid, &pw, pwbuf, sizeof(pwbuf), &pwp);
+AC_CACHE_CHECK(
+       [for call semantics from getpwuid_r], 
+       ac_cv_call_getpwuid_r,
+       [AC_TRY_COMPILE([#include <sys/types.h>
+#include <pwd.h>], 
+                         [
+                               struct passwd pw, *pwp;
+                               char pwbuf[64];
+                               uid_t uid;
+
+                               getpwuid_r(uid, &pw, pwbuf, sizeof(pwbuf), &pwp);
+                       ],
+                       ac_cv_call_getpwuid_r=yes, 
+                       ac_cv_call_getpwuid_r=no)
+       ])
 
-],
-ac_cv_call_getpwuid_r=yes, ac_cv_call_getpwuid_r=no)])
 if test $ac_cv_call_getpwuid_r = no; then
        AC_DEFINE(SOLARIS_GETPWUID)
        AC_DEFINE(F_UID_T, "%ld")
@@ -631,6 +660,27 @@ else
        AC_DEFINE(F_XPID_T, "%x")
 fi
 
+dnl AC_CHECK_FUNCS(res_query)
+AC_CACHE_CHECK([for the resolver calls], 
+              ac_cv_resquery_ok, 
+[AC_TRY_COMPILE([#include <netinet/in.h>
+#include <arpa/nameser.h>
+#include <resolv.h>], 
+               [
+                       char *domain="www.google.com";
+                       u_char *answer;
+                       int len;
+                       len = res_query( domain, C_IN, T_A, answer, PACKETSZ );
+               ],
+                ac_cv_resquery_ok=yes,
+               ac_cv_resquery_ok=no)
+])
+echo "resquery: $ac_cv_resquery_ok"
+
+dnl if test "$ac_cv_resquery_ok" = "no" ; then
+dnl    AC_DEFINE(RES_QUERY_GONE, "#error resquery not here. can't continue.")
+dnl fi
+
 
 
 AC_CACHE_CHECK([for ut_host in struct utmp], ac_cv_struct_ut_host,