Honor retry time
[citadel.git] / citadel / configure.ac
index aa900202e81668c0b37421fdc576e255df7ae86f..eb757b2753acadbce1a8e48c28b5a91bf7b1b05f 100644 (file)
@@ -1,6 +1,6 @@
 dnl Process this file with autoconf to produce a configure script.
 AC_PREREQ(2.52)
-AC_INIT([Citadel], [8.29], [http://www.citadel.org/])
+AC_INIT([Citadel], [909], [http://www.citadel.org/])
 AC_REVISION([$Revision: 5108 $])
 AC_CONFIG_SRCDIR([citserver.c])
 AC_CONFIG_HEADER(sysdep.h)
@@ -414,7 +414,7 @@ dnl Checks for libraries.
 dnl We want to test for the following in libc before checking for their
 dnl respective libraries, because some systems (like Irix) have both, and the
 dnl non-libc versions may be broken.
-AC_CHECK_FUNCS(crypt gethostbyname connect flock getpwnam_r getpwuid_r getloadavg)
+AC_CHECK_FUNCS(crypt gethostbyname connect getpwnam_r getpwuid_r getloadavg)
 
 AC_CHECK_FUNCS(strftime_l uselocale gettext)
 
@@ -565,59 +565,6 @@ AC_CHECK_HEADER(libcitadel.h,
 CFLAGS="$saved_CFLAGS"
 
 
-AC_CHECK_LIB(cares, ares_parse_mx_reply,
-            [
-                    C_ARES_LIBS=-lcares
-                   AC_DEFINE(HAVE_C_ARES, 1, [Define to use c-ares library])
-                    have_good_c_ares=yes
-            ],, $SOCKET_LIBS $NSL_LIBS
-)
-
-
-
-saved_CFLAGS="$CFLAGS"
-CFLAGS="$CFLAGS $SERVER_LIBS"
-dnl Check for c-ares
-AC_CHECK_HEADER(ares.h,
-       [AC_CHECK_LIB(cares, ares_parse_mx_reply,
-               [
-                       LIBS="-lcares $LIBS $SERVER_LIBS"
-               ],
-               [
-                       AC_MSG_ERROR(libc-ares was not found or is not usable.  Please install libc-ares.)
-               ]
-       )],
-       [
-               AC_MSG_ERROR(ares.h was not found or is not usable.  Please install libc-ares.)
-       ]
-)
-CFLAGS="$saved_CFLAGS"
-
-saved_CFLAGS="$CFLAGS"
-CFLAGS="$CFLAGS $SERVER_LIBS"
-dnl Check for libev
-AC_CHECK_HEADER(ev.h,
-       [AC_TRY_COMPILE([#include <math.h>
-#include <ev.h>], 
-                         [
-                        ev_cleanup abort_by_shutdown;
-                        struct ev_loop *event_base;
-                        ev_cleanup_start(event_base, &abort_by_shutdown);
-                       ],
-                       [
-                       LIBS="-lev -lm $LIBS $SERVER_LIBS"
-                       ],
-               [
-                       AC_MSG_ERROR(libev was not found or is not usable.  Please install libev.)
-               ])
-       ],
-       [
-               AC_MSG_ERROR(ev.h was not found or is not usable.  Please install libev.)
-       ]
-)
-CFLAGS="$saved_CFLAGS"
-
-
 # The big search for OpenSSL
 if test "$with_ssl" != "no"; then
        saved_LIBS="$LIBS"