* modules registering serverports now need to specify a plaintext name.
[citadel.git] / citadel / debian / rules
index fef1a8bf64bad9fa1b826c56e1602220305e944a..0b4a8020b86259eca4f684a57b18700dec53572b 100755 (executable)
@@ -10,11 +10,14 @@ DEB_DESTDIR = $(CURDIR)/debian/tmp
 
 CFLAGS = -Wall -g
 
-#ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0 -ggdb -pg
-#else
-#      CFLAGS += -O2
-#endif
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -O0 -ggdb -rdynamic -D_GNU_SOURCE -MD -MP 
+       LDFLAGS += -pg 
+       SERVER_LDFLAGS += -lm
+#      SERVER_LDFLAGS += -pg
+else
+       CFLAGS += -O2
+endif
 
 configure: configure-stamp
 configure-stamp:
@@ -35,7 +38,8 @@ configure-stamp:
                --with-zlib \
                --with-ldap \
                --with-libical \
-               --with-libsieve
+               --with-libsieve \
+               --enable-debug
 
        touch configure-stamp