'Network User' is now 'Normal User'
[citadel.git] / citadel / debian / rules
index 9217bc55a3f3822680cafb65be6340f22748450b..431f8985a6c4c289a468dc2b65d0862513b0b307 100755 (executable)
@@ -16,7 +16,7 @@ CFLAGS = -Wall -g -Werror=format-security
 COMPILER=
 EXTRA_ARGS=
 PROFILE_ARGS=
-#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling threadoff rss gcov clang"
+#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling threadoff rss gcov clang cares"
 ifneq (,$(findstring clang,$(DEB_BUILD_OPTIONS)))
         COMPILER="clang" 
 endif
@@ -25,7 +25,7 @@ ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
 endif
 
 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0 -ggdb -rdynamic -D_GNU_SOURCE -MD -MP -D TECH_PREVIEW
+       CFLAGS += -O0 -ggdb -rdynamic -D_GNU_SOURCE -MD -MP -D TECH_PREVIEW -Wcast-align
        LDFLAGS+=-Wl,--no-undefined -Wl,--as-needed
        EXTRA_ARGS = --with-backtrace
        ifneq (,$(findstring event,$(DEB_BUILD_OPTIONS)))
@@ -54,8 +54,12 @@ ifneq (,$(findstring rss,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -D DEBUG_RSS
 endif
 
+ifneq (,$(findstring cares,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -D DEBUG_CARES
+endif
+
 ifneq (,$(findstring iodbg,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -D BIGBAD_IODBG
+       CFLAGS += -D BIGBAD_IODBG -D LDAP_INITIALIZE
 endif
 
 ifneq (,$(findstring gcov,$(DEB_BUILD_OPTIONS)))
@@ -67,7 +71,7 @@ configure: configure-stamp
 configure-stamp:
        dh_testdir
 
-       CC=$(COMPILER); LDFLAGS="$(LDFLAGS)"; CFLAGS="$(CFLAGS)" ./configure \
+       export CC=$(COMPILER); export LDFLAGS="$(LDFLAGS)"; export CFLAGS="$(CFLAGS)"; ./configure \
                --prefix=/var/lib/citadel/ \
                --with-datadir=/var/lib/citadel/ \
                --with-helpdir=/usr/share/citadel-server/ \