* dump message headers on artv dump
[citadel.git] / citadel / debian / rules
index c0ca8031ced686c11f5ed43d536e1bc607eec81e..4c651a403fc6fe151758504c12f5b23916dd3c56 100755 (executable)
@@ -13,7 +13,7 @@ CFLAGS = -Wall -g
 
 EXTRA_ARGS=
 PROFILE_ARGS=
-#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling"
+#to enable debugging: export DEB_BUILD_OPTIONS="debug profiling threadoff"
 ifneq (,$(findstring profiling,$(DEB_BUILD_OPTIONS)))
        PROFILE_ARGS= --with-gprof
 endif
@@ -24,6 +24,12 @@ else
        CFLAGS += -O2
 endif
 
+ifneq (,$(findstring threadoff,$(DEB_BUILD_OPTIONS)))
+       THREAD_ARGS=--without-threaded-client
+else
+       THREAD_ARGS=
+endif
+
 configure: configure-stamp
 configure-stamp:
        dh_testdir
@@ -44,7 +50,7 @@ configure-stamp:
                --with-ldap \
                --with-libical \
                --with-libsieve \
-               --enable-debug $(EXTRA_ARGS) $(PROFILE_ARGS)
+               --enable-debug $(EXTRA_ARGS) $(PROFILE_ARGS) $(THREAD_ARGS)
 
        touch configure-stamp