* OpenBSD compatibility: select properly while reading/writing to sockets
[citadel.git] / citadel / debian / rules
index 4c651a403fc6fe151758504c12f5b23916dd3c56..501fed62c721f094d469e68c3394355e8affcf8c 100755 (executable)
@@ -4,6 +4,9 @@
 #export DH_VERBOSE=1
 
 # This has to be exported to make some magic below work.
+DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
 export DH_OPTIONS
 
 DEB_DESTDIR = $(CURDIR)/debian/tmp
@@ -73,7 +76,7 @@ clean:
        dh_testroot
        rm -f build-arch-stamp build-indep-stamp configure-stamp
 
-       -$(MAKE) distclean
+       [ ! -f Makefile ] || $(MAKE) distclean
 
        dh_clean 
        rm -f config.status config.log