Libevent integration
[citadel.git] / citadel / debian / rules
index b9e067b2ff5b424c5f6e73190ee9437579ae76ff..5c51eb473f202bc1d74720eb58abf7b9790ba5f9 100755 (executable)
@@ -24,6 +24,9 @@ ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0 -ggdb -rdynamic -D_GNU_SOURCE -MD -MP -D TECH_PREVIEW
        LDFLAGS+=-Wl,--no-undefined -Wl,--as-needed
        EXTRA_ARGS = --with-backtrace
+       ifneq (,$(findstring event,$(DEB_BUILD_OPTIONS)))
+               EXTRA_ARGS = --with-backtrace --with-experimental_eventsmtp
+       endif
 else
        LDFLAGS+=-Wl,--no-undefined -Wl,--as-needed
        CFLAGS += -O2