* sending the startup-problem-message now does work.
[citadel.git] / citadel / debian / rules
index 0b4a8020b86259eca4f684a57b18700dec53572b..a3dfde6e9210a7f6d5a363a64f2844aa4cfcc398 100755 (executable)
@@ -10,11 +10,12 @@ DEB_DESTDIR = $(CURDIR)/debian/tmp
 
 CFLAGS = -Wall -g
 
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0 -ggdb -rdynamic -D_GNU_SOURCE -MD -MP 
        LDFLAGS += -pg 
        SERVER_LDFLAGS += -lm
 #      SERVER_LDFLAGS += -pg
+       EXTRA_ARGS = --with-profiling --with-backtrace
 else
        CFLAGS += -O2
 endif
@@ -39,7 +40,7 @@ configure-stamp:
                --with-ldap \
                --with-libical \
                --with-libsieve \
-               --enable-debug
+               --enable-debug $(EXTRA_ARGS)
 
        touch configure-stamp